Just in case this helps even one other person, I am posting this quick tip. I am a long time AMD user, bought a new i7-9700k laptop with a 1660ti graphics card and have been getting horrible performance and frame rates in ddo, < 32 fps. I was not aware, and perhaps others are not, that Nvidia will throttle power to the GPU in a couple of cases. In my case, it was doing it as a default setting and on my dual screen when it thought the focus was on the other display. You can correct this by using the Nvidia control panel to set the power options and gpu for just DDO.

Instructions are similar to this thread (https://www.nvidia.com/en-us/geforce...-power-saving/), but I just used the second tab page to set only DDO and the 64 bit version as I don't want my laptop running everything all the time in full power. Frame rates are now where I would expect them, well over 150 on ultra high. Note that if you have sync to display turned on in advance graphics your max fps shown will match your monitor, you can uncheck to see what FPS you would be pushing on a higher display.

Ddo is again a pleasure to play!