Results 1 to 5 of 5
  1. #1
    Community Member
    Join Date
    Aug 2015

    Question Microphone & Voice Chat Not Working Since Mojave Update

    I have been a longtime DDO player and enthusiast on two different iterations of Macbook laptops. Since the Mojave update a few weeks ago, neither my microphone or the speaking part of voice chat have worked on DDO, though the listening part works fine. I have exhausted technical support's suggestions. This is really beginning to limit my enjoyment of the game, so I wanted to see if anyone else has had similar problems and fixed them, or to see whether a fix is hopefully coming soon? A family member of mine who also plays has also experienced the exact same issue on DDO since the update, so I suspect that it is not an issue with my specific installation or settings.

    My microphone works on other applications in Mojave.
    Occasionally an "allow DDO to access the microphone" window pops-up during game, to which I hit "allow," with no subsequent change.
    DDO is checked as an application "allowed" to use the microphone in my Mojave privacy settings.
    My character bar icon does not show the standard green border either when I hit the push-to-talk button (my standard way) or when I check the handsfree voice mode and speak into the microphone.
    When I enable the "mic test" no bars are shown from input.
    I don't use Discord or any other microphone-utilizing applications (that I am aware of).
    My voice-capture threshold is set for 0.04.
    Connecting to a party voice-chat server takes longer than I remember, but still occurs after about a minute or so, at which point I can hear other party members talking.

    --Troubleshooting steps I have tried:
    Using an external USB headset/microphone
    Using a bluetooth headset/microphone
    Using the built-in mac microphone
    (Ensuring each of the above were selected in DDO settings)
    Adding DDO to allowed applications in the firewall.
    Disabling the firewall.
    Unchecking, restarting, and rechecking the "allow" checkbox for microphone usage for DDO in privacy settings.
    Uninstalling and Reinstalling DDO via Steam, whereas my previous installation was via Happy Cloud
    Starting mac in "Safe Mode" (DDO won't load in that setting)

    Additionally, while don't assume this is connected to my specific issue, DDO now takes about 5-7 minutes to load after entering my username and password and selecting my server, where it used to take just a matter of seconds.

    I would love if anyone had any ideas to try! Or if someone could potentially comment on whether this may be fixed soon if it is a program issue. I'm looking forward to having voice chat back working again!

  2. #2
    Community Member
    Join Date
    May 2018


    Quote Originally Posted by speakerofjargon View Post
    I wanted to see if anyone else has had similar problems
    I can confirm that it isn't just you. I have also not been able to successfully use my microphone since the Mojave update. Unfortunately, it isn't evident to me that DDO cares about its Mac users-- this is just one of many issues currently experienced by all Mac users (including the delayed log-in issue you briefly mentioned in your post).

    I won't be spending another penny on this game unless they start supporting Macs.
    "All we have to decide is what to do with the time that is given us."

  3. #3
    Community Member
    Join Date
    Jul 2015

    Default "Kobold not comfortable with this!"

    I am also a 2018 Macbook Pro user. After the latest Mojave update, I am experiencing the same problem. The description is quite accurate! I have been playing DDO since release in 2006 and have been very pleased with Standing Stone's support and management. After two + weeks, I am beginning to worry about the OS support. I have tried 90% of the above mentioned fixes prior to seeing this post and can independently confirm "no joy". "Kobold not comfortable with this!" Or as Leloo would say "Plaese... halp me".

    Thanks for all the hard work, we still love the game!

  4. #4
    Community Member
    Join Date
    Aug 2015

    Default Fixed!

    As a followup, this issue has now been resolved! The game loads quickly after the login screen, and my microphone works!

    Thanks Devs!

  5. #5
    Community Member
    Join Date
    Mar 2014


    Long time player... new to Mac. Just got a new Mac Book Pro ... really looking forward to playing the game on my new Mac. After a few weeks finally got the game to load and able to play. Problem is I can't get my mic to work. I know how to select all the buttons in the game ... and I have a mic in all the other apple applications. Cant get push to talk or hands free to work. Ive tried both Beats (blue tooth) and a cheap Logitech usb. Again Im new to Mac .. any suggestions? Be kind

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.