Results 1 to 4 of 4
  1. #1
    Community Member Glowmaster's Avatar
    Join Date
    Dec 2010
    Location
    South Eastern USA
    Posts
    12

    Question Master's Touch not working lately

    My arcane builds are Eldritch Knights until roughly level 12. I pass around a Carnifex as I need and just cast Master's Touch on it to have proficiency with it.
    Last night (Friday, June 30th) I noticed that I still had the message on my screen that I'm not proficient after I cast the Master's Touch spell while holding the Carnifex.
    I figured it might be bugging and it may go away the next time I log in. Logged in tonight and tried it again with the same result.

    Does anyone else have this issue? I've been doing this with no problems for over 6 years on all my arcane casters.
    Server: Sarlona
    Guild: P H O E N I X
    Rank: Guild Leader
    Characters: Tankarrd, Sydwynder, Kushinna, Tankmonk, Teykoff, Prefrontal, and Ayrielle

  2. #2
    Community Member Torkzed's Avatar
    Join Date
    Oct 2009
    Posts
    299

    Default

    I know this is probably an unnecessary question, but you are not trying to scroll cast it, are you?

  3. #3

    Default

    The message is definitely about Carnifex? It's not about armor you aren't proficient with, or a shield, or even just telling you you're encumbered and/or not centered (if you have monk levels)?

  4. #4
    Community Member spyyder976's Avatar
    Join Date
    Feb 2006
    Posts
    622

    Default

    Master's Touch is also not working for me. I keep casting it, and it keeps telling me that I'm still not proficient with the martial weapon and shield, although it should.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload