Results 1 to 8 of 8
  1. #1
    Community Member PadrePio's Avatar
    Join Date
    Aug 2010
    Location
    Italy
    Posts
    149

    Default Forums and security certificate

    Hello,
    I'm having problems connecting to the forums from my phone, because it says the security certificate the forum is using is not trusted by my device's operative system (I've got a OnePlus Two with Android 5.1.1, Oxygen version 2.2.1).
    Here is a screenshot:


    Is there anything I can do about it?
    Thanks.
    Vetafer - Iolho - Finkbrau
    Thelanis

  2. #2
    Community Member
    Join Date
    Apr 2013
    Location
    Athens
    Posts
    2,126

    Default

    Quote Originally Posted by PadrePio View Post
    Is there anything I can do about it?
    Thanks.
    Is there anything you can do about it? Yes. Click on the "proceed to www.ddo.com (unsafe)"

    Is there anything the devs can do about it? Yes. Fix the certificate for all ddo's pages so this message does not appear. (the login page is already certified and the forums seem certified by COMODO CA)
    My main server is Khyber. Have toons in almost every server for favor purposes. The Faltouts

  3. #3
    Hopeless Romantic dunklezhan's Avatar
    Join Date
    Sep 2009
    Location
    Yorkshire Toxic Fringe Zone
    Posts
    6,337

    Default

    Yeah I'm seeing this again on android - it was gone for a good while, but as of the last few weeks its back.
    Quote Originally Posted by Vargouille View Post
    The best of the best DDO players generally overperform when given a real challenge
    Quote Originally Posted by Amundir View Post
    My words are great. Even out of context.

  4. #4
    Community Member Greantun's Avatar
    Join Date
    Apr 2013
    Posts
    684

    Default

    Quote Originally Posted by dunklezhan View Post
    Yeah I'm seeing this again on android - it was gone for a good while, but as of the last few weeks its back.
    ddo.com uses a root certifier that I haven't really seen often: COMODO SECURE. Most likely your device does not have that as a root certificate and therefore can't validate the certificate for ddo.com

    Not knowing much about android, or other devices, I am not sure how you get that root certificate on your device. On desktops and laptops, they usually come with OS Upgrades or specific installs from the OS manufacturer.

  5. #5
    Community Member
    Join Date
    Mar 2011
    Posts
    84

    Default

    The same thing happens on my Android phone and tablet periodically and it's pretty annoying. The last time all of the nice formatting and background images went away and all the links were listed out like a 1990`s bulletin board.

    The last couple of times I've been able to get rid of it by clearing the browser history and restarting the browser. I just did this earlier in the week and it's working fine for me right now.

    Good luck! Hope it clears up for you soon!

  6. #6
    Community Member PadrePio's Avatar
    Join Date
    Aug 2010
    Location
    Italy
    Posts
    149

    Default

    Quote Originally Posted by Faltout View Post
    Is there anything you can do about it? Yes. Click on the "proceed to www.ddo.com (unsafe)"
    Sure, but it has to be done every single time you load a page (say go to a sub-forum, then again to a specific thread etc etc.)



    Quote Originally Posted by Bobmj
    The last couple of times I've been able to get rid of it by clearing the browser history and restarting the browser. I just did this earlier in the week and it's working fine for me right now.

    Good luck! Hope it clears up for you soon!
    Unfortunately I tried and it didn't work for me ..

    Thanks everyone for the help
    Vetafer - Iolho - Finkbrau
    Thelanis

  7. #7
    Founder & Hero
    2016 DDO Players Council
    Uska's Avatar
    Join Date
    Jan 2006
    Location
    Behind you with a claw hammer
    Posts
    25,365

    Default

    The problem comes and,goes lately on my tablet and phone


    Beware the Sleepeater

  8. #8
    Community Member
    Join Date
    Sep 2009
    Posts
    1

    Default

    I was going to start a new thread but I found this one via scanning thread topics. (and yes I realize it's a few months old)

    The SSL certificate is actually installed incorrectly - https://www.ssllabs.com/ssltest/anal...?d=www.ddo.com

    A quick mention of what the issue is and how to fix it - https://community.qualys.com/thread/11685

    There's other issues as well but the review site links to them. This thread discusses the broken chain issue.

    I do hope that this matter can be cleared up quickly.

    edit: As a humorous aside, I used to review bank websites. Would you believe 70%-ish of those get F's?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload