Results 1 to 10 of 10
  1. #1
    Dual-Wielder of Halflings dozkal-mo's Avatar
    Join Date
    Sep 2009
    Posts
    737

    Default RSS Feeds from DDO Forum

    Hello Everybody!

    My guild uses Shivtr for its official guildpage and ever since the data center change, the RSS feeds fail to load on our site. Nothing changed on Shivtr (they give us notes and such when updates come down the pipe) and since it coincided with this data center exchange, it seemed a bit coincidental.

    Anyone have any suggestions on what happened? I checked the links for the RSS feeds and they all appear to be the same.

    Gracias, amigos.
    Officer and Webmaster for Fallen Immortals, a guild of Thelanis.

    Toons: Aryllia, Dayanmak, Devhead, Gezgin, Kutsal, Toprak

  2. #2
    Dual-Wielder of Halflings dozkal-mo's Avatar
    Join Date
    Sep 2009
    Posts
    737

    Default

    Nobody? Not one suggestion?
    Officer and Webmaster for Fallen Immortals, a guild of Thelanis.

    Toons: Aryllia, Dayanmak, Devhead, Gezgin, Kutsal, Toprak

  3. #3
    Community Member changelingamuck's Avatar
    Join Date
    Mar 2011
    Location
    The Demiplane of Dread
    Posts
    1,708

    Default

    Bumping this because I've searched around and found no answers to the exact same question.

  4. #4
    dozkal-ne
    Guest

    Default

    Quote Originally Posted by changelingamuck View Post
    Bumping this because I've searched around and found no answers to the exact same question.
    I am glad I'm not the only one. I've searched several times since my original post and found nothing.

  5. #5
    Community Member changelingamuck's Avatar
    Join Date
    Mar 2011
    Location
    The Demiplane of Dread
    Posts
    1,708

    Default

    Quote Originally Posted by dozkal-ne View Post
    I am glad I'm not the only one. I've searched several times since my original post and found nothing.
    Yeah... I'm going to wait and see until this coming Tuesday for this bump of this thread to drum up any solutions. If it doesn't produce a resolution, then I'll bring the issue up in the players council forums because it is a really important thing for guild/fan sites to be able to receive forum RSS feeds (and far more important than the usual forum squabbling over oncoming doom, power creep, nerfs, and such that I myself indulge in much too often, admittedly). Guild/fan sites are no-cost support for DDO's bottom-line, after all.

    If you can make a thread in the Shivtr user forums about the problem before Tuesday and PM me a link before Tuesday, it would help me communicate the issue to the developers. I have a feeling that it's going to require communicating with 'so-and-so' who then has to talk to 'what's-her-name' who then has to talk to 'that guy' who calls his buddy in Department X to figure it out. And hearing something from the Shivtr people as soon as possible that says "It's not a problem on our end," would speed things up, I'd wager. Thanks for starting the thread though because if you hadn't done so, I might've imagined that my RSS feeding attempts were just scuttled by my own lack of know-how. Much appreciated.

    If anyone looking at this thread does guild hosting using something other than Shivtr and you have functional RSS feeds on your site for the DDO forums, please comment in this thread.

    Edit: Or even if any readers of this thread don't have functional RSS feeds on guild/fan sites that they've tried to get working, please comment and say what guild site hosting service that you've used that you haven't been able to get working RSS feeds on (and the date of the last time you tried to get the RSS feed to work).

  6. #6
    Community Manager
    Cordovan's Avatar
    Join Date
    Nov 2010
    Location
    Boston Area, MA
    Posts
    28,741

    Default

    I can look into this next week. I am not aware of anything changing, and the RSS feeds like Dev Tracker are clearly working on DDO.com. If Shivtr is pointing to an IP address, that would have changed with the data center move, but I will need to see how Shivtr gets its RSS info.
    Have fun, and don't forget to gather for buffs!
    Follow DDO on: Facebook Twitter YouTube
    Join us on Twitch!
    Hello from Standing Stone Games! Facebook Twitter
    For Support: https://help.standingstonegames.com



  7. #7
    YourDDO Creator
    2015 DDO Players Council
    Team Turbine 2015 Mo-Bro
    Ague's Avatar
    Join Date
    Oct 2009
    Location
    <string table error;TableDID
    Posts
    844

    Default

    OP, hope you find this useful:

    If you're trying to get an RSS feed from the DDO forums here, you have to use a URL like this:

    http://www.ddo.com/forums/external.php?type=rss&forumids=3 (that one specifically points to Service News)
    http://www.ddo.com/forums/external.php?type=rss&forumids=73 (that one is for release notes forums)

    If you want more info (and providing Shivtr supports it), you can use RSS2 feeds by just adding a '2' after 'rss' in the link.

    Example:
    http://www.ddo.com/forums/external.php?type=rss2&forumids=73 (again, the release notes)

    If you need ATOM feed, it appears as though you can replace 'rss' or 'rss2' with 'atom', but it provides the same info and format as 'rss2'. vBulletin also supports plain xml feeds, but it appears as though that option is turned off on these forums.

    You can make any forum category into an RSS feeds. You just have to change the forumsids=# to get different data. The same applies to any vBulletin based forum (unless the forum administrator has RSS turned off for whatever reason in the admin cp).

    You can also feed several forums or threads in one url by making the 'forumids' into a comma seperated list of forums/threads.

    Example:
    http://www.ddo.com/forums/external.php?type=rss2&forumids=3,73

    And in case you're wondering where I got the numbers for forumids from, simply open any forum here and look for the following number in the URL:

    Example (using General Discussion in this example):
    https://www.ddo.com/forums/forumdisplay.php/37-General-DDO-Discussion (the number 37, in this example is what you would put in the forumids)

    So, I'm thinking that all you would have to do is update the RSS url and you should be good to go.

    Of special note: It appears that the Dev Trackers are already specialized RSS feeds all of their own, so linking to them in an external RSS url just redirects to the Dev Tracker forum and will likely not work as intended if you try to link to it from Shivtr.

    Anyways, hope that help get your working again on your Shivtr page.

    UPDATE: So I just made a site on Shivtr to test this out and it seems that using the https:// at the beginning of the RSS feed URL doesn't work, BUT removing the 's' in https (ie making it http://) works like a charm. I could go into a lengthy explanation as to why that way, but I'll spare you the lengthy tech-babble. See the feeds in action here: http://thedungeoncrawlers.shivtr.com/ (scroll to the bottom). i also removed the 's' in question from the examples above.
    Last edited by Ague; 07-02-2016 at 09:35 PM.


  8. #8
    Community Member Franghasea's Avatar
    Join Date
    Jul 2013
    Posts
    67

    Default Feed Aggregator

    Greetings!

    Perhaps this is tied to the Feed Aggregator here, https://www.ddo.com/en/aggregator , which hasn't updated since the data center move.

    Franghasea

  9. #9
    Community Member changelingamuck's Avatar
    Join Date
    Mar 2011
    Location
    The Demiplane of Dread
    Posts
    1,708

    Default

    Quote Originally Posted by Ague View Post
    UPDATE: So I just made a site on Shivtr to test this out and it seems that using the https:// at the beginning of the RSS feed URL doesn't work, BUT removing the 's' in https (ie making it http://) works like a charm. I could go into a lengthy explanation as to why that way, but I'll spare you the lengthy tech-babble. See the feeds in action here: http://thedungeoncrawlers.shivtr.com/ (scroll to the bottom). i also removed the 's' in question from the examples above.
    This was the issue for me. I actually use a plugin for more secure browsing that automatically makes every possible web address HTTPS, called HTTPS Everywhere. And, of course, I didn't remember that I'd installed it and was copying the added 's' when copying-and-pasting.

    Thanks for all of the helpful tips. +1
    Last edited by changelingamuck; 07-08-2016 at 02:38 PM. Reason: corrected a grammatical error

  10. #10
    Community Manager
    Cordovan's Avatar
    Join Date
    Nov 2010
    Location
    Boston Area, MA
    Posts
    28,741

    Default

    Quote Originally Posted by changelingamuck View Post
    This was the issue for me. I actually use a plugin for more secure browsing that automatically makes every possible web address HTTPS, called HTTPS Everywhere. And, of course, I didn't remember it that I'd installed it and was copying the added 's' when copying-and-pasting.

    Thanks for all of the helpful tips. +1
    This belongs in the Dev tracker.
    Have fun, and don't forget to gather for buffs!
    Follow DDO on: Facebook Twitter YouTube
    Join us on Twitch!
    Hello from Standing Stone Games! Facebook Twitter
    For Support: https://help.standingstonegames.com



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload