Results 1 to 13 of 13
  1. #1
    2015 DDO Players Council Seikojin's Avatar
    Join Date
    Feb 2006
    Location
    gamertown usa
    Posts
    7,441

    Default Cannot patch Turbinelauncher.exe, error 5: access is denied

    Tried to patch today and get that error message. Still investigating. Tried using the one from backup and one from lamania. same issue. Replaced all files from backup folder and patch is not proceeding.

  2. #2
    Scholar Of Adventure & Hero Missing_Minds's Avatar
    Join Date
    Jun 2006
    Location
    work....
    Posts
    30,449

    Default

    Quote Originally Posted by Seikojin View Post
    Tried to patch today and get that error message. Still investigating. Tried using the one from backup and one from lamania. same issue. Replaced all files from backup folder and patch is not proceeding.
    Do you suppose it could be requiring akami now?

    I'm assuming you are running as admin, and that you did not install to "program files"?

  3. #3
    2015 DDO Players Council Seikojin's Avatar
    Join Date
    Feb 2006
    Location
    gamertown usa
    Posts
    7,441

    Default

    Quote Originally Posted by Missing_Minds View Post
    Do you suppose it could be requiring akami now?

    I'm assuming you are running as admin, and that you did not install to "program files"?
    Akami is installed and running fine (never turned it off)... Firewall is set to ignore both ddo and akami... Installed to C:\Program Files (x86)\Turbine\Dungeons & Dragons Online

    Definitely running as admin.

    dndclient.log:
    Code:
    000000000.000: Invalid Command-line "C:\Program Files (x86)\Turbine\Dungeons & Dragons Online\dndclient.exe" : You must specify an account name
    Turbineclientlauncher.log (from appdata\local):
    Code:
    //****************************************************************************************
    // Filename: C:\Users\<username removed>\AppData\Local\Dungeons & Dragons Online\turbineclientlauncher.log
    // Description: Crash Debug Launcher Log
    // Version: 2600.0044.3721.4088.RELEASE Portal:compiled Fri Jul 11 03:48:29 2014 : RELEASE
    // Process ID: 2844 (0xb1c)	Thread ID: 14844 (0x39fc)
    // Log Creation Time: Wed Jul 16 08:27:23 2014
    // Current Time - System: Wed Jul 16 08:27:23 2014	Game: 000000000.000
    // Times wrapped: 0	Writes: 0	Bytes Written: 0
    //****************************************************************************************
    000000000.051: Launched with args: [C:\Program Files (x86)\Turbine\Dungeons & Dragons Online\turbineclientlauncher.exe]
    000000000.051: Crash Receiver  []
         Dump Type  [mini]
      Upload Dumps  [TRUE]
       Client Args  []
        Executable  [C:\Program Files (x86)\Turbine\Dungeons & Dragons Online\dndclient.exe]
               PID  [0]
       Working Dir  [C:/Program Files (x86)/Turbine/Dungeons & Dragons Online/]
      Artifact Dir  [C:\Users\<username removed>\AppData\Local\Dungeons & Dragons Online\]
    000000002.972: Create Debugged Process: 1, process handle: 396, thread handle: 84, processID: 12308, threadID: 10012
    	Command Line ["C:\Program Files (x86)\Turbine\Dungeons & Dragons Online\dndclient.exe" ] 
    	Working Dir [C:/Program Files (x86)/Turbine/Dungeons & Dragons Online/]
    000000002.972: CheckForOldCrashes: Looking for pending .crashuploadcontext ... in [C:\Users\<username removed>\AppData\Local\Dungeons & Dragons Online\]
    000000005.341: UPDATE VERSION FROM PROCESS: Branch: dnd_live Version: 2600.0044.3721.4088
    000000016.917: EXIT_PROCESS_DEBUG_EVENT: The program '[12308]' has exited with code 4984820 (0x1)
    @@@ END OF FILE @@@
    Could not find the third log file though. The folder for it is not present.
    Last edited by Seikojin; 07-16-2014 at 12:48 PM.

  4. #4
    Scholar Of Adventure & Hero Missing_Minds's Avatar
    Join Date
    Jun 2006
    Location
    work....
    Posts
    30,449

    Default

    Well, looks like you aren't the only one. Iv'e seen a few other similar titled threads pop up.

    All I can say at this point is good luck. I got nothing else.

    edit: Oh... but I see you do have it in program files. On your next re install I would suggest to not put it there. Windows gets extra picky about permissions there. I placed it in a different non programfile directory C:\Turbine I think I named it. Never got hit by a lot of issues that others did.
    Last edited by Missing_Minds; 07-16-2014 at 02:26 PM.

  5. #5
    2015 DDO Players Council Seikojin's Avatar
    Join Date
    Feb 2006
    Location
    gamertown usa
    Posts
    7,441

    Default

    Quote Originally Posted by Missing_Minds View Post
    Well, looks like you aren't the only one. Iv'e seen a few other similar titled threads pop up.

    All I can say at this point is good luck. I got nothing else.
    Sall good. I put in tickets and bugs, mentioned in livestream (didn't get noticed though). So hopefully something will get brought into action. I am going to bring a working launcher file tomorrow and see if that works.

  6. #6
    2015 DDO Players Council Seikojin's Avatar
    Join Date
    Feb 2006
    Location
    gamertown usa
    Posts
    7,441

    Default

    I sent myself a copy of the patched file from a working machine and it worked. A bigger problem: their patcher is not properly validating files and replacing bad ones.

  7. #7
    Community Member
    Join Date
    Sep 2016
    Posts
    1

    Thumbs up Same Problem

    I had this exact same problem, but after finding a support help page I founds a very simple solution. Go into your games directory and right click on both TurbineLauncher.exe & TurbineInvoker.exe and under compatibility apply "run as adminitrator" apply both and click ok. then launch the launcher again and all should be fine. I'm currently just waiting for mine to finish updating them i'm back to playing.

  8. #8
    Community Member
    Join Date
    Jun 2010
    Posts
    331

    Default

    Quote Originally Posted by DLS1989 View Post
    I had this exact same problem, but after finding a support help page I founds a very simple solution. Go into your games directory and right click on both TurbineLauncher.exe & TurbineInvoker.exe and under compatibility apply "run as adminitrator" apply both and click ok. then launch the launcher again and all should be fine. I'm currently just waiting for mine to finish updating them i'm back to playing.
    I had the same problem, and this solved it.
    Afunkymunky/Drkivorkian, Helter Skelter on Ghallanda

    Epic Ring of Spell Storing--https://www.ddo.com/forums/showthrea...+spell+storing

  9. #9
    Community Member
    Join Date
    Nov 2010
    Posts
    399

    Default Problem again cropped up with Today's (7/14/17) Hot Fix ...

    Quote Originally Posted by DLS1989 View Post
    I had this exact same problem, but after finding a support help page I founds a very simple solution. Go into your games directory and right click on both TurbineLauncher.exe & TurbineInvoker.exe and under compatibility apply "run as adminitrator" apply both and click ok. then launch the launcher again and all should be fine. I'm currently just waiting for mine to finish updating them i'm back to playing.
    Unfortunately, this has not worked. On "troubleshooting compatibility" option, I receive the error message:

    There was a problem starting SelfPatch.dll
    The specific module could not be found.

    This occurred both before and after an uninstall and a full reinstallation. Program keeps hanging at the 44% "Check Product, Updating Files" process of the patch installation.

    Any new suggestions?

  10. #10
    Community Member
    Join Date
    Nov 2010
    Posts
    399

    Default Problem Resolved ... or just beginning?

    From the other post ...

    Quote Originally Posted by Vish View Post
    Hi, the story
    Yesterday tried to patch u36
    Got errors patching, at the 44% point ...

    Something tells me there is some script not allowing access?
    I've never had this problem before
    Don't know who's end its on
    Thanks for help
    Hi. I didn't follow most of what you did. I had no problem with Wednesday fix nor yesteray's U36 patch. But today (Friday) was a different story: the patch process stopped very early, getting hitched at the 44% mark, as is the case with you. The error received was: Cannot patch Turbinelauncher.exe, error 5: access is denied (See previous post).

    The solutions I tried there did not help. Another post from a long time ago suggested copying the files from the backup folder to the main directory. And strangely, I couldn't effect the copy as I was denied access to the file, despite the administrator privileges (!).

    Another error messaging indicated a failure to load a module from the PatchClient.dll in the DDO folder; while the Task Manager required shutting down the rundll32 application of the Windows Operating System. So, as the old rundll seemed to be in play, I decided to perform a System Restore. After doing this, I was able to patch in the hot fix and get the game started ... after wasting a good six hours of trouble shooting.

    But I am concerned. The Restore Point was prior to a "Critical Update" on Tuesday, 7/11. Will I experience this problem again soon? And I am bothered about the "sudden" appearance of the lack of Administrator privilege when I tried to copy over the Turbinelauncher.exe from the backup folder.

  11. #11
    Community Member glmfw1's Avatar
    Join Date
    Oct 2014
    Location
    UK
    Posts
    830

    Default

    I switched to Run as Administrator, then restarted and after that it worked.

    The same change with a shut down and then turn on again did not work.

    Of course my timing could have coincided with a hotfix fix.
    Bettayne Brah'dukcc, Cleric of Lathander
    Today is the first day of the rest of your life

  12. #12
    Community Member wolfman1969's Avatar
    Join Date
    May 2009
    Posts
    1

    Default how do you fix this

    Quote Originally Posted by Seikojin View Post
    Tried to patch today and get that error message. Still investigating. Tried using the one from backup and one from lamania. same issue. Replaced all files from backup folder and patch is not proceeding.
    how do i fixthis

  13. #13
    2015 DDO Players Council Seikojin's Avatar
    Join Date
    Feb 2006
    Location
    gamertown usa
    Posts
    7,441

    Default

    Quote Originally Posted by wolfman1969 View Post
    how do i fixthis
    Quote Originally Posted by Seikojin View Post
    I sent myself a copy of the patched file from a working machine and it worked. A bigger problem: their patcher is not properly validating files and replacing bad ones.
    Basically the offending/called out file in the log was replaced from an install of the game on a secondary machine and I could patch and log in.

    I have noticed though, that ever since Akamai has become the file distribution service and the launcher has been changed: Some files get installed/patched poorly and corrupt updating. The only resolution is to uninstall and reinstall the game over and over again until it works.

    It would be nice if there was a location with a patched, updated, downloadable offline installer. So you have less dynamic failure from distributed delivery systems/services.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload