Results 1 to 7 of 7
  1. #1
    Community Member NexEverto's Avatar
    Join Date
    Oct 2009
    Location
    Australia
    Posts
    796

    Post NVIDIA ShadowPlay + DDO = Input Freeze Weirdness

    NVIDIA ShadowPlay has just been released as BETA for my Graphics Card (GeForce GTX 675MX) and I’m finding it great for streaming and recording in the other games I play. In DDO however, I’m getting some sort of weird input latency/freezing where my keystrokes will basically be ‘eaten’ every few seconds, occasionally when they aren't removed from existance, I'll get a 'wall' of them which causes my character to have a fit (Often leaving me drowning in Lava). DDO is the only game that has this issue, as all other games I've tested on work fine.

    I know of other people who use ShadowPlay with similar Laptop Cards and they don't report this issue. Does anyone else that uses Shadow Play have this issue? Any fixes or tips?
    || Arari - Cleric Rogue || Athyria - Satanic Mechanic || Ethirial - Arcane Archer || Tiarinlasa - Spell Singer || Zirron - Divine Avenger ||


  2. #2
    Community Member -Zephyr-'s Avatar
    Join Date
    Feb 2010
    Posts
    1,263

    Default

    I'm one of those "other people" enjoying Shadowplay very much on my GeForce GTX 770M ; and I have no idea what I am doing differently.
    Owy Evoker FvS / Praledric Completionist Qstaff Rogue/Monk/Druid / Laraeph DC Wizard / Laraelph AA Monk/Ranger/Pally / Gaenry Shiradi Sorc/FvS/Wiz / Reasis SWF Pally & numerous others
    The Leveller for DDO!

  3. #3

    Default

    Hey NexEverto,

    Are you using a factory default laptop? In other words, one you bought fully loaded and haven't reinstalled the OS. Many times those will come with software installed that is used to make all those "special" function keys do something. That software does so by intercepting keystrokes at a hardware level, supposedly forwarding them up the chain, which bypasses DDO's keystroke input mechanism. If you have such an application installed, it could be causing this problem.

    I can't tell you exactly what to check for because each OEM uses a different application. Run MSConfig and take a look at the "Startup" tab to see what's being loaded. If you're on Windows 8.1 that will take you to the Task Manager which is where the functionality resides now.

    Best of luck!
    The newest computer can merely compound, at speed, the oldest problem in the relations between human beings, and in the end the communicator will be confronted with the old problem, of what to say and how to say it. - Edward R. Murrow (1964)

  4. #4
    Community Member NexEverto's Avatar
    Join Date
    Oct 2009
    Location
    Australia
    Posts
    796

    Default

    Quote Originally Posted by sebastianosmith View Post
    Hey NexEverto,

    Are you using a factory default laptop? In other words, one you bought fully loaded and haven't reinstalled the OS. Many times those will come with software installed that is used to make all those "special" function keys do something. That software does so by intercepting keystrokes at a hardware level, supposedly forwarding them up the chain, which bypasses DDO's keystroke input mechanism. If you have such an application installed, it could be causing this problem.

    I can't tell you exactly what to check for because each OEM uses a different application. Run MSConfig and take a look at the "Startup" tab to see what's being loaded. If you're on Windows 8.1 that will take you to the Task Manager which is where the functionality resides now.

    Best of luck!
    Nice suggestion! I'm running a custom install on my laptop, however I d use the default hotkey service. I've tried disabling it and running ShadowPlay in DDO, and unfortunately I still get the input freezes.

    Zephyr, do you use Hotkey 6.0100 on your laptop? I know we've got pretty similar Builds so I imagine you might.
    || Arari - Cleric Rogue || Athyria - Satanic Mechanic || Ethirial - Arcane Archer || Tiarinlasa - Spell Singer || Zirron - Divine Avenger ||


  5. #5

    Default

    Quote Originally Posted by NexEverto View Post
    Nice suggestion! I'm running a custom install on my laptop, however I d use the default hotkey service. I've tried disabling it and running ShadowPlay in DDO, and unfortunately I still get the input freezes.
    Sorry that didn't work. It was worth a shot.

    I did a little more digging on this issue and discovered that the problem appears to afflict laptops only. No one on the Nvidia or Steam forums has discovered a fix or workaround yet. There were some suggestions about disabling Aero in Win7 or Vista (still a thing ) while ShadowPlay is running. It was reported that doing so will virtually eliminate recording lag but does nothing about input lag.

    I guess it's up to Nvidia to fix at this point.
    The newest computer can merely compound, at speed, the oldest problem in the relations between human beings, and in the end the communicator will be confronted with the old problem, of what to say and how to say it. - Edward R. Murrow (1964)

  6. #6
    Community Member -Zephyr-'s Avatar
    Join Date
    Feb 2010
    Posts
    1,263

    Default

    Quote Originally Posted by NexEverto View Post
    Nice suggestion! I'm running a custom install on my laptop, however I d use the default hotkey service. I've tried disabling it and running ShadowPlay in DDO, and unfortunately I still get the input freezes.

    Zephyr, do you use Hotkey 6.0100 on your laptop? I know we've got pretty similar Builds so I imagine you might.
    Hmm, I'm not even sure what that is! Took all my drivers (except wifi because it hated Win7) directly from Asus - Windows 8 versions despite running on Windows 7. My keyboard driver is "ATKACPI driver and hotkey-related utilities".

    Do you have GeForce Exprience 2.1.0.0 or 2.0.1.0? Forgot to ask yesterday.
    I know the latest release broke my ShadowPlay, and I had to reinstall the older then upgrade, manually, twice, to get it working.
    Last edited by -Zephyr-; 06-10-2014 at 12:32 PM.
    Owy Evoker FvS / Praledric Completionist Qstaff Rogue/Monk/Druid / Laraeph DC Wizard / Laraelph AA Monk/Ranger/Pally / Gaenry Shiradi Sorc/FvS/Wiz / Reasis SWF Pally & numerous others
    The Leveller for DDO!

  7. #7
    Community Member NexEverto's Avatar
    Join Date
    Oct 2009
    Location
    Australia
    Posts
    796

    Default

    Quote Originally Posted by sebastianosmith View Post
    Sorry that didn't work. It was worth a shot.

    I did a little more digging on this issue and discovered that the problem appears to afflict laptops only. No one on the Nvidia or Steam forums has discovered a fix or workaround yet. There were some suggestions about disabling Aero in Win7 or Vista (still a thing ) while ShadowPlay is running. It was reported that doing so will virtually eliminate recording lag but does nothing about input lag.

    I guess it's up to Nvidia to fix at this point.
    No need to be sorry! It's probably one of the best suggestions anyone has given me.

    Interesting that you've seen other people complain about the same issues, specifically on Laptops. I've only been able to find one other instance of it, and they were having it across all games (Where I'm just having the problem with DDO).

    If NVIDIA or Turbine are the only two that can fix it, I'm screwed, as I imagine neither of them care about my problems all that much.

    Still, time will tell I guess.

    Quote Originally Posted by -Zephyr- View Post
    Hmm, I'm not even sure what that is! Took all my drivers (except wifi because it hated Win7) directly from Asus - Windows 8 versions despite running on Windows 7. My keyboard driver is "ATKACPI driver and hotkey-related utilities".

    Do you have GeForce Exprience 2.1.0.0 or 2.0.1.0? Forgot to ask yesterday.
    I know the latest release broke my ShadowPlay, and I had to reinstall the older then upgrade, manually, twice, to get it working.
    Right, forgot you have a Asus, and not a bastardized Clevo like me. I'm running 2.1.0.0, however I've had this same issue with DDO in all the previous versions too. NVIDIA seems to disagree with my laptop, and any time I do a NVIDIA driver update it uninstalls my GeForce Exprience. I might try blanket removing all my Graphics drivers this weekend and starting fresh.

    Though, what do you mean it 'broke' your ShadowPlay?
    || Arari - Cleric Rogue || Athyria - Satanic Mechanic || Ethirial - Arcane Archer || Tiarinlasa - Spell Singer || Zirron - Divine Avenger ||


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload