Results 1 to 9 of 9

Thread: Annoying hum.

  1. #1
    Community Member
    Join Date
    Nov 2010
    Posts
    80

    Default Annoying hum.

    When ever I have focus on a DDO window (either windowed or full screen), I get an annoying hum. It will change volume and pitch depending on what I am doing. If just standing it is usually fairly soft but still clearly audible and at a low frequency. It I start spinning around it gets louder and higher pitched. It usually also gets higher pitched and maybe louder when I am running.

    I do not get the hum though the headphones for voice chat (mic and speakers).

    I do get the hum even if I set to minimum all effects on the audio options page.

    I do get the hum even with the head set unplugged so no microphone.

    I stop getting the hum if I am in windowed mode and I click outside the window, or if in full screen and I do a control alt delete.

    I normally use a television for my monitor and speakers for all except voice chat. The hum also appears on my Logitech speakers when connected (2.1) and on my Vizio speakers when connected (5.1). It is much louder on the computer speakers and I think it might have actually damaged the base on the Logitech speakers.

    I do get the hum even when I use Microsoft and set the audio to minimum (0) and when I mute the speakers.

    I can only get the hum to disappear by turning the volume on the hardware (volume adjustment on speakers and on television) to so low it cannot be heard (all sounds gone).

    To my knowledge the problem only appears when in a DDO window. I have tried reproducing in Firefox, Magicjack, WinTV7, VLC, Mediaplayer, and several other computer games.

    I have searched the web for information on possible conflicts between Realtek and DDO. I find nothing. I know the following information is probably overkill but hopefully someone can see something I cannot.

    Typically I have the following programs running: AwesomiumProcess(x7), conhost.exe, csrss.exe, dllhost.exe (COM Surrogate), dndclient.exe*2, dwm.exe, explorer.exe, firefox.exe*32, FlashPlayerPlugin_13_0_0_214.exe*32 (x2), F-Secure (FSM32.EXE*32, fshoster32.exe*32), IAStorIcon.exe*32, NVidia Software (NvBackend.exe*32, nvstreamsvc.exe, NvTmru.exe*32, nvtray.exe, nvvsvc.exe, nvxdsync.exe) plugin-container.exe*32 (firefox), ramdiskws.exe (SoftPerfect RAM), RAVBg64.exe, RAVCpl64.exe, SwUSB.exe, taskhost.exe, taskmgr.exe, winlogin.exe, and YahooMessenger.exe (x2).

    I have removed all but AwesomiumProcess(x7), conhost.exe, csrss.exe, dllhost.exe (COM Surrogate), F-Secure (FSM32.EXE*32, fshoster32.exe*32), NVidia Software (nvstreamsvc.exe, nvvsvc.exe, nvxdsync.exe) RAVBg64.exe, SwUSB.exe, taskhost.exe, taskmgr.exe, and winlogin.exe and the hum does not go away.

    I keep Windows 7 Professional version 6.1.7601 Service Pack 1 Build 7601 with all patches through May 9, 2014 (autoupdate on Fridays at 03:00 Central US time and it did run last Friday I know).

    My hardware is:
    i7-4770k unlocked
    ASRock Z87 Extreme 3 motherboard
    32GB PC1600 DDR3 memory
    EVGA NVidia Geforce GTX 760 with 4GB memory x2 in SLI configuration
    Hauppauge TV tuner card
    Audio controllers listed in Device Manager (Starred I see in DDO Audio options)
    Hauppauge WinTV HVR-1255 (Model 22xxx, Hybrid ATSC/QAM)
    * Logitech USB headset (I use for the voice chat)
    NVIDIA High Definition Audio (on video card 1, I think)
    NVIDIA High Definition Audio (on video card 2, I think)
    NVIDIA Virtual Audio Device (Wave Extensible) WDM (I have no idea where unless on video cards also)
    * Realtek High Definition Audio (on motherboard)

    On audio options screen Sound Playback choices are:
    Generic Software on Speakers (Realtek High Definition Audio)
    Generic Software on Speakers (2- Logitech USB Headset)
    Generic Software on Realtek Digital Output (Realtek High Definition Audio)
    I have tried both choices 1 and 3 and both hum. I cannot choose the Logitech USB headset. I think it is because set for Voice Playback Device and Voice Capture Device. I do not know why the NVIDIA High Definition Audio and NVIDIA Virtual Audio Device do not appear in the list.

  2. #2

    Default

    I'm a computer tech by trade, but there's a lot going on with your system so my advice will be limited.

    A hum is indicative of RF interference. Based on your system's description, it's not store-bought unit but a custom job. As with any computer, RF interference can happen if any electrical device connected to the computer is not shielded correctly, leading to frequency energies leaking about.

    You have a Hauppauge tuner card. TV signals, even digital, can generate a different level of RF that a computer might not shield properly.

    Your description also suggests that the feedback from both the internal speakers and Logitech may be due to loose connections with the headset, the speakers, or shielding on either item.

    Since you don't get the hum while outside of the game, it could still be a software matter. Are you using DirectX 9? If you're using newer versions, it might be causing audio hiss or hums as you're describing.

    If you get the hum without the microphone, is there any other sound input on the computer, even if nothing is plugged in? There may be a hardware issue with the card and/or its drivers in terms of how DDO "listens" or polls available devices or inputs, even if they aren't in use.

    It does sound like the Realtek hardware is the problem. If possible, enter the BIOS and disable the sound card hardware if settings allow it, and then test again. If the hum disappears, then the built-in sound doesn't jibe with DDO and an external card might help.
    Editor, The Book of Syncletica: An unofficial DDO Monk Guide, and Stormreach Shadows: An unofficial DDO Stealth Guide
    The Order of Syncletica: A DDO-flavored blog on Monks and gameplay and more
    (formerly known as Spencerian)

  3. #3
    Hatchery Hero BOgre's Avatar
    Join Date
    Jan 2011
    Location
    Middlonowhere, Alberta, Canada
    Posts
    3,065

    Default

    I doubt very much that it's hardware. You've said that you can't repro in any other game or app. If it was hardware, it'd be everywhere.

    My guess is either

    DX9/10/11 (redownload the distributable, uninstall, reinstall)
    - or -
    EAX (turn eax OFF in DDO audio settings, and/or redownload eax enabled drivers for you sound card, uninstall, reinstall)
    Quote Originally Posted by Towrn
    ...when the worst thing that happens when you make a mistake at your job is someone complains on the internet, you probably care a little less!

  4. #4
    Community Member twigzz's Avatar
    Join Date
    Mar 2006
    Location
    MI
    Posts
    779

    Default

    I had an annoying hum once, I never talked to her again....


    I'd try what BOgre said tho.

  5. #5
    Community Member
    Join Date
    Nov 2010
    Posts
    80

    Default

    I checked EAX and it is not Enabled. Here are my current Audio options:
    Master Volume - 1.00
    Sound Effects Volume - 0.00
    Combat Sound Volume - 0.00
    Music Volume - 0.00
    Ambient Sound Volume - 0.00
    Dungeon Master Narration - 0.06
    User Interface Volume - 1.00
    Sound Playback - Generic Software on Speakers (Realtek High Definition Speakers)
    Focus Loss Behavior - Persist Sound
    Enable EAX - unchecked
    Disable Game Sounds - checked
    Turn Off DM Audio - checked
    Enable Voic Chat - checked
    Mic Test - unchecked
    Hands Free Voice - checked
    Voice Volume - 1.00
    Voice Microphone Gain - .24
    Voice Capture Threshold - .09
    Voice Playback Latency (ms) - 115.0
    Voice Playback Device - Speakers (2- Logitech USB Headset)
    Voice Capture Device - Microphone (2- Logitech USB Headset)


    The system is not a complete custom build. It is a customized (at MicroCenter at time of purchase) PowerSpec G400. I had the wireless card removed, the TV-tuner card put in, the power supply upgraded, and original video card removed (??, It might have just been changed from integrated video) and replaced with dual EVGA NVIDIA Geforce 760s.

    DirectX Diagnostic Tool indicates the Directx version is DirectX 11. The rest of the report is super long. It is stored on my Charter Communications webspace. The file is at webpages.charter.net/ranma28/DxDiag.txt.

    I did find this line in the report 3 times: " EAX(tm) 2.0 Listen/Src: No, No". It appeared for each audio device. Also the notes on the DxDiag on the screen all said "No problems found."

    I am looking for the download for DirectX 11. Microsoft is only pointing to Windows 8.1 versions and I do not trust most of the www.get-my-driver.com type sites. Can you have multiple versions of DirectX on your system? I know that DDO at least used to recommend only DirectX 9.0c. If both 9.0c and 11 can be installed simultaneously I will add 9.0c.

  6. #6

    Default

    Quote Originally Posted by TalieNeEllyll View Post
    I am looking for the download for DirectX 11. Microsoft is only pointing to Windows 8.1 versions and I do not trust most of the www.get-my-driver.com type sites. Can you have multiple versions of DirectX on your system? I know that DDO at least used to recommend only DirectX 9.0c. If both 9.0c and 11 can be installed simultaneously I will add 9.0c.
    All DX downloads for Windows 8.x are now done through the Windows Update service. The last redistributable version (9.0c) can be found here. Newer versions of DX are generally backwards compatible with DX8.x and forward with a few deprecation exceptions. Installing 9.0c on Windows 8.1 won't hurt anything, but do run Windows Update manually afterwards if you install it.

    As for your audio hum... It is probably RF interference of one type or another. I can suggest a few possible fixes.

    The first is to completely uninstall the Realtek audio drivers, using a driver cleaner if possible, and reinstalling the latest version from Realtek's site. I honestly do not expect that to fix the problem, but you may get lucky.

    Try turning off any mic dB boosting you may have enabled or simply lowering the recording volume. dB boosting can be found in the Realtek control panel on the Microphone tab. Click the button to the far right of the volume slider that looks like a potato wearing headphones. While you are there, set the recording volume slider to about 25%. If you've already tried updating the drivers, these will probably be reset to default anyway.

    As strange as this sounds, turn on VSync. The problem as you've described it sounds very much like harmonic power cycle interference. I have no idea what refresh rate your monitor (TV) supports, but enabling VSync will force it to the default. This will, of course, lock your maximum FPS to the same speed. Doing this may either eliminate the hum or make it worse. Either way you've learned something.

    If you are using HDMI out to the monitor, try using a VGA or DVI cable if possible. The shielding on many HDMI cables is almost nonexistent. If you are using a DVI-HDMI converter, see if you can remove that from the chain as those are also very leaky.

    My last recommendation is to move the power cord for your speakers to a circuit other than the one your computer and monitor are on. If the power cycle harmonics from the monitor are feeding back through the speaker power adapter, that should clear up the problem.

    That's about all I can come up with at the moment. I hope something I've said helps.

    Best of luck!
    Last edited by sebastianosmith; 05-20-2014 at 07:37 AM.
    The newest computer can merely compound, at speed, the oldest problem in the relations between human beings, and in the end the communicator will be confronted with the old problem, of what to say and how to say it. - Edward R. Murrow (1964)

  7. #7
    Community Member
    Join Date
    Nov 2010
    Posts
    80

    Default

    @sebastionosmith,

    THANK YOU!!!

    I decided to start with the simplest of your suggestions. All my equipment is plugged into a single double something UPS. (Full electrical isolation). Unfortunately my area has HORRID power doing things like frying the circuitry in refrigerators, stoves, washing machines, ... Well I unplugged my monitor from the UPS and plugged directly into the wall. It fixed it. Now I guess I just have to buy a second UPS for the monitor. I can get a small one though. My UPS is 1500 watt is the biggest I could buy for home use. I think I should be able to use a 500 watt if all I keep on it is the monitor.

    As to DirectX, I guess you missed that my OS is Windows 7 Professional SP1 build 7601 (first post of the thread). That is why I am having problems at the MS site. I can only find for the 8.1 versions.

  8. #8

    Default

    Quote Originally Posted by TalieNeEllyll View Post
    @sebastionosmith,

    THANK YOU!!!

    I decided to start with the simplest of your suggestions. All my equipment is plugged into a single double something UPS. (Full electrical isolation). Unfortunately my area has HORRID power doing things like frying the circuitry in refrigerators, stoves, washing machines, ... Well I unplugged my monitor from the UPS and plugged directly into the wall. It fixed it. Now I guess I just have to buy a second UPS for the monitor. I can get a small one though. My UPS is 1500 watt is the biggest I could buy for home use. I think I should be able to use a 500 watt if all I keep on it is the monitor.

    As to DirectX, I guess you missed that my OS is Windows 7 Professional SP1 build 7601 (first post of the thread). That is why I am having problems at the MS site. I can only find for the 8.1 versions.
    Glad I could help. Sorry about confusing your OS. That link to the 9.0c redistributable will still work for you.

    One final thought - You really shouldn't be getting line noise through a UPS. They usually have pretty good RFI/EMI filters in them, well, good enough anyway to prevent what was happening to your speakers. I suspect your UPS has four or six outlets on it, only some of which are actually connected to the battery circuit; the others being (supposedly) filtered line outlets. If your monitor was plugged in one of those, something is very wrong. Even if it wasn't, something is wrong. I'd get that checked.

    Best of luck!
    Last edited by sebastianosmith; 05-21-2014 at 07:14 AM.
    The newest computer can merely compound, at speed, the oldest problem in the relations between human beings, and in the end the communicator will be confronted with the old problem, of what to say and how to say it. - Edward R. Murrow (1964)

  9. #9
    Community Member TopazScorpion's Avatar
    Join Date
    Sep 2006
    Posts
    11

    Thumbs up

    Quote Originally Posted by sebastianosmith View Post
    As strange as this sounds, turn on VSync. The problem as you've described it sounds very much like harmonic power cycle interference. I have no idea what refresh rate your monitor (TV) supports, but enabling VSync will force it to the default. This will, of course, lock your maximum FPS to the same speed. Doing this may either eliminate the hum or make it worse. Either way you've learned something.
    Great advice Sebastian!
    I have had this annoying hum for the longest time exactly the same as TalieNeEllyll outlined. It would ONLY happen when playing DDO. No other apps or media had the issue. I tried all of the things mentioned in these posts (DX version, different power outlet, reinstall DDO, driver updates, etc...) and nothing fixed it.

    What fixed it for me was the Video Sync settings in DDO. Here is how:
    I use nVidia cards exclusively so if you are using some other card find the info in whatever control panel they have.

    1. Open the nVidia control panel and go to Display -> Change Resolution
    2. Note the refresh rate for your monitor. Mine is 60Hz
    3. Open DDO and go into the Options Panel and select the Adv Graphics tab.
    4. Scroll down to the bottom of the window and find the Refresh Rate pull-down
    5. Select the Refresh Rate you found in Step 2
    6. Select (check mark in box) the Sync With Refresh Rate option

    And that worked for me. That annoying hum went away immediately.

    Great job folks.

    The one drawback to this fix is that it locks your frame rate (Viewable in DDO using CTRL-F) to your Refresh Rate. So now I have to decide between Annoying Hum or Higher Frame Rates. Before this fix my frame rate was about 340. With this fix it stays right around 60 (my refresh rate). Sigh... always something.
    Last edited by TopazScorpion; 08-23-2014 at 02:20 PM. Reason: Caveat is frame rate

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload