Results 1 to 2 of 2

Thread: New Airships

  1. #1
    Community Member
    Join Date
    Dec 2010

    Default New Airships

    I tried buying one of the new ships. Had just guided to Guild level 200, and I had more than enough plat and shards deposited at the airship merchant.

    I could not buy the deluxe (shards) versions of the new ships.
    I therefore settled on a basic Man-o-War (the largest of the three new ones - Frigate, Cruiser, Man-o-War.)

    The ship itself looks very large and pretty cool - (pirate) hats off to the ship designers.

    When I am onboard, the text switches to channels named 'Cruiser - Advice', 'Cruiser - General' and so on. Looks a little odd - should the channel be called 'Man-o-War'?
    Hit the button to reveal hook points, but they didn't show up until I changed decks.
    Could not place any amenities - clicked on the now visible hookpoints, but this had no effect on any of the first/second/third decks. I did not try placing anything in the cargo hold.

    So I logged out and back in.

    I showed as being on location 'Cruiser' in the login page, not 'Man-o-War'.

    I could now place amenities on the second deck, but the first and third decks were still not working.
    I logged out and back in again. Could now place one or two amenities on the first deck, but the hookpoints then went dead again.

    I placed a throne room on a side room (small hookpoint) on the first deck, and promptly got stuck in part of its scenery. I teleported to the harbor and then re-entered the ship.

    Nothing was visible on the top deck apart from First Mate String Error, the Captain and the buffs button - no hook points etc. Should we be placing the Bank/Auctionhouse/Mailbox on the closest deck and going down to that deck to use them, or will they appear on the deck if present on the ship somewhere?

    I also noted that it assumes you will be buying everything from personal funds as opposed to guild funds.
    Will you need to be an officer to place/change/buy amenities, or to use guild funds?

  2. #2
    2014 DDO Players Council Flavilandile's Avatar
    Join Date
    Aug 2010


    Yes I got also weird stuff with the Man-o-war.

    - Amenities that don't let you enter in ( a wall barring the area once you place it ) [ Bug reported with screenies ] { Bug : 24207-67025 }
    - I also got hit by the nothing shows on First Deck when I pushed the button to reveal the hookpoints.
    [ until I changed deck ]
    - I also got hit by the hookpoints becoming unresponsive.

    Since it was late I didn't make bug reports for the last two issue...
    On G-Land : Flavilandile, Blacklock, Yaelle, Millishande, Larilandile, Gildalinde, Tenalafel, and many other...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.