Results 1 to 3 of 3
  1. #1
    Community Member
    Join Date
    Mar 2014

    Default Connection keeps getting lost.

    Dear DDO community,

    Yesterday I have installed Dungeons and Dragons online via steam. I started playing
    and immedietly after logging in I got the "connection lost" popup and my game stopped.
    I restarted and it worked (yiihee!). However, after playing for 10 more minutes I got the
    same error; "connection lost" popup and my game crashed again.
    After some research on the internet, I found out that more people have the issue
    of needing to restart DDO before being able to play. However; I can't find
    any good solution for the "connection lost" after 10 minutes. It just keeps

    Things I tried:
    -Running windowed mode (someone mentioned it)
    -Running it besides steam (just launching the Turbinelauncher.exe)

    If there is anyone that can help me, I would be very very grateful!


  2. #2
    Community Member
    Join Date
    Mar 2014


    This problem has so far not been solved.
    I live on my own and I can run the game on my laptop, but whenever I'm at my parent's house,
    I just get this problem... I'm really hoping anyone can tell me how to solve this since the game
    is very, very cool!


  3. #3


    Yea me to, but i lose connection when i'm trying to create a character

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.