Results 1 to 2 of 2
  1. #1
    Community Member SynalonEtuul's Avatar
    Join Date
    Dec 2010

    Default Anyone else having trouble with the store?

    I've tried to add points a few times now but invariably I receive a message telling me there was "an error processing your request" and recommending I try again in a few minutes. I've tried both credit card and PayPal. Is anyone else having this problem or am I alone here?

  2. #2
    Community Member Rubix's Avatar
    Join Date
    Aug 2007


    I had a similar problem with the store a while back and called support. They advised me to relog my details on on When that didn't help I called called again and was told that if your zip code is fewer than 5 digits, eg. not in the US, then try adding a leading zero. that did it for me and I I haven't had any problems since.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.