Results 1 to 7 of 7
  1. #1
    Community Member
    Join Date
    Mar 2010
    Posts
    4

    Default Low FPS on MacBook Pro 17 Native Mac Beta CLient

    I have installed the new Mac Beta client on both my iMac and my 3 year old MacBook and I get a terrible frame rate (~10 FPS) on the MacBook, but the iMac works great.

    I have run DDO in a windows emulator on this same laptop, and it was fine.

    MacBook Specs:
    Processor 2.53 GHz Intel Core i5
    Memory 8 GB 1067 MHz DDR3
    Graphics NVIDIA GeForce GT 330M 512 MB
    Software Mac OS X Lion 10.7.5 (11G63)

    The FPS only improves marginally any when I adjust the graphics to even their lowest settings. So I am thinking it is not a problem with the graphics

    And when I watch my character move in the world from another machine (running from in my house) it is jumpy as though the connection with the server is the problem.

    The internet connection to my house is excellent, and it works fine on the iMac.

    The problem persists even if the MacBook client is the only one running.

    Any ideas? I did try the resetting the SCM, no luck.

  2. #2
    Community Member
    Join Date
    May 2013
    Posts
    4

    Default

    I posted this in another thread, but I'm having the same terrible FPS problem on a Retina Macbook Pro that works great in Bootcamp. I almost wonder if it's detecting/using the integrated graphics instead of the discrete graphics, but I'm just speculating.

  3. #3
    Community Member
    Join Date
    Mar 2010
    Posts
    4

    Default

    Its a reasonable guess. The whole game is slow, but in underground dungeons the play improves.

  4. #4
    Community Member
    Join Date
    May 2013
    Posts
    4

    Default

    This thread motivated me to take another stab at this, and happily I got it working, because DDO is pretty much the only reason I ever boot into Windows these days.

    Instead of launching it using the supplied launcher in Applications, everything works fantastic if I bypass it and just run the Launcher manually from the terminal:

    $ /Users/Shared/Happycloud/Cache/DNDLauncher.app/Contents/MacOS/DNDLauncher

    I am now getting 70+ frames per second at with Ultra High settings and 2880x1800 resolution, although I know I need to turn Post Effects off to get rid of some bugs.

    Would be curious to know if this works for you too.

  5. #5
    Community Member
    Join Date
    Mar 2010
    Posts
    4

    Default

    I restarted the same machine with Mountain Lion and it works fine.

  6. #6
    Community Member
    Join Date
    Mar 2010
    Posts
    4

    Default

    Or that's the reason. I have two partitions and I ran it off the old one from the directory you suggested. So no I don't no what fixed it.

  7. #7
    Community Member
    Join Date
    Jul 2009
    Posts
    4

    Default

    That worked for me. Thanks!

    Quote Originally Posted by Xerxax View Post
    This thread motivated me to take another stab at this, and happily I got it working, because DDO is pretty much the only reason I ever boot into Windows these days.

    Instead of launching it using the supplied launcher in Applications, everything works fantastic if I bypass it and just run the Launcher manually from the terminal:

    $ /Users/Shared/Happycloud/Cache/DNDLauncher.app/Contents/MacOS/DNDLauncher

    I am now getting 70+ frames per second at with Ultra High settings and 2880x1800 resolution, although I know I need to turn Post Effects off to get rid of some bugs.

    Would be curious to know if this works for you too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload