Results 1 to 3 of 3
  1. #1
    Community Member
    Join Date
    Feb 2010
    Posts
    25

    Default Enhancement revamp broke my trapmonkey Arti

    Before the changes to enhancements my arti was a pretty darn good trapmonkey, able to spot, search, and disable all but the most extreme traps. Now he's nearly worthless at traps. I did a quest with a friend and my arti was three levels above the quest level and he embarrassed himself on the traps. He was passable at disabling them, but his search was terrible and his spot didn't work at all. I know they changed trap DCs, but is this in line with what they had planned? If so, then lucky they gave us the lesser hearts because I'll rebuild him to not be a trapmonkey at all.

  2. #2
    Community Member
    Join Date
    Oct 2010
    Posts
    81

    Default

    What race? What level? Wearing the appropriate gear? Neither of my Artificers, one human and one half-elf, have had issues with any elite-level trap in the game so far.

  3. #3
    Community Member
    Join Date
    Apr 2010
    Posts
    2,012

    Default

    Quote Originally Posted by Inconel View Post
    Before the changes to enhancements my arti was a pretty darn good trapmonkey, able to spot, search, and disable all but the most extreme traps. Now he's nearly worthless at traps. I did a quest with a friend and my arti was three levels above the quest level and he embarrassed himself on the traps. He was passable at disabling them, but his search was terrible and his spot didn't work at all. I know they changed trap DCs, but is this in line with what they had planned? If so, then lucky they gave us the lesser hearts because I'll rebuild him to not be a trapmonkey at all.
    I have also been having problems using 'spot' recently - I'm hoping it's a bug... I mean, you put all your points into it, it's maxxed out, you have the maximum possible spot item, you even slot a dang clear gem with a wisdom item for the bonus... and traps are still not showing up reliably on elite (heroic) quests.

    All of my arti splashes are having this problem; even our pure rogue (multiple lives) was having this issue.

    If this is WAI, then... I guess.... spot might as well be a dump stat, as even maxxed out and devoting item slots to it, its a fail.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload