Results 1 to 3 of 3
  1. #1
    Community Member
    Join Date
    Jun 2013

    Default DDO cuts out all other sound.

    Whenever I start DDO, it cuts out all other sound, including youtube videos, and spotify. But the moment I shut down DDO. The sound returns.

    How do i fix this because I like ot listen to music while I play. this JUST started happening.

  2. #2
    Community Member
    Join Date
    Jul 2010


    Assuming you are on Windows Vista or 7, they allow an application to take exclusive control of your sound card; this allows for lower latancies, but prevents other programs from playing sound simultaneously.

    To disable this, right-click the volume icon in the system stray, and select "Playback Devices". In the window that opens, double-click on your speakers in the list, then click the "Advanced" tab in the new window that pops up. Clear the tick from the "Allow applications to take exclusive control of this device" option, and OK back out. Repeat for your headphones if you use them, and hopefully you should be set.

    Edit: Back to the drawing board... I've just tried playing music from VLC and firing DDO up and I could hear both fine, with the exclusive mode enabled. Hmmm....
    Last edited by gypsythief; 06-23-2013 at 06:12 AM.

  3. #3
    Community Member
    Join Date
    Aug 2013


    gypsythief, thanks I had the same issue

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.