Results 1 to 3 of 3
  1. #1
    Community Member
    Join Date
    Jun 2013
    Posts
    4

    Exclamation Mac DDOLauncher Problem - Help!

    I'm new to all of this, but I have a pretty nasty problem for me. I've done many online games but I can't get around the problem that I have here. I downloaded the DDOLauncher from the website for Mac, and as far as I know I have met all the system requierments. The problem is, whenever I try to open it after the download it says and I quote:

    “DNDLauncher” is damaged and can’t be opened. You should move it to the Trash.

    Any help from you guys?

  2. #2
    Customer Service Representative Mirthgar's Avatar
    Join Date
    Mar 2008
    Posts
    1,170

    Default

    Quote Originally Posted by Arisalin View Post
    I'm new to all of this, but I have a pretty nasty problem for me. I've done many online games but I can't get around the problem that I have here. I downloaded the DDOLauncher from the website for Mac, and as far as I know I have met all the system requierments. The problem is, whenever I try to open it after the download it says and I quote:

    “DNDLauncher” is damaged and can’t be opened. You should move it to the Trash.

    Any help from you guys?
    Under the apple menu in system preferences > security > general ensure that 'allow applications from anywhere' is selected.

    NOTE: The Customer Support forums are best for Player-to-Player help, for more direct and official support, please submit a ticket to the appropriate team via the form here.

    After contacting support, log into your email webpage to add noreply@turbine.com and accountsupport@turbine.com to their "safe senders" list and your contacts list/address book. Be sure to check Spam/Junk Mail folders as well since most email providers do not let external email programs or cell phones download mail flagged this way.

  3. #3
    Community Member
    Join Date
    Jun 2013
    Posts
    4

    Default

    Quote Originally Posted by Mirthgar View Post
    Under the apple menu in system preferences > security > general ensure that 'allow applications from anywhere' is selected.
    Wow. That would do it I 'spose...

    I've fixed that and am redownloading. Hopefully that was it. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload