Results 1 to 3 of 3
  1. #1
    Community Member thouston07's Avatar
    Join Date
    Nov 2009
    Posts
    30

    Default Delera's Tomb--Soul Lock glitch

    In the third part of the chain, Free Delera, I've hit a glitch twice now that one of the soul locks won't register as being 'opened', rendering the quest uncompletable. Anyone else have this issue?

  2. #2
    Community Member redspecter23's Avatar
    Join Date
    Jul 2007
    Location
    Toronto, Ontario
    Posts
    3,688

    Default

    It's a known issue right now. If you're hit or interrupted while activating an object, you will often complete the activation but will not get credit for it in your quest log. It's slightly annoying for optional objectives like in Delera's part 3, but it's extremely annoying in a quest where it's a mandatory activation like Gianthold Tor or Dead Shall Rise. You can lock yourself out of a completion and be forced to restart in those situations.
    Kaarloe - Degenerate Matter - Argonnessen

  3. #3

    Default

    Quote Originally Posted by redspecter23 View Post
    It's a known issue right now. If you're hit or interrupted while activating an object, you will often complete the activation but will not get credit for it in your quest log. It's slightly annoying for optional objectives like in Delera's part 3, but it's extremely annoying in a quest where it's a mandatory activation like Gianthold Tor or Dead Shall Rise. You can lock yourself out of a completion and be forced to restart in those situations.
    It's not an optional in Delera's part 3; it's the primary objective. Meaning that like Tor, you're forced to reset the instance. (Or ask a GM to complete for you.)

    It's also an issue in necro 2 where you extinguish all the altars, something like 16 of them, with the nonstop barrage of respawning incorporeals.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload