Well here's the skinny.

I got the update and then tried to login. It told me that the parameter "Steam" could not be null. It would be null because I didn't install via Steam.

I then tried to make this topic on the forums and paste in the details of the error in hopes that it would help turbine in resolving them. The forums then crapped out on me and told me I there was some sort of Security certificate error.

I restarted my machine and now the launcher won't even load. It's in my task manager sitting on 5 megs of ram but I can't cancel it, nothing is displayed, and only a reboot shut it off.

And I swear to the bloody twelve if it won't let me post THIS I am probably going to be done with this game.

My question is do I have to un-install and reinstall to fix, and if so should I be using Steam, is that your favored platform now?

Also ... well nevermind actually ... I hear Mom's voice in my head about not saying anything if you can't say anything nice so ... yeah that's it.

TL;DR -> Do I need to reinstall via steam to resolve my issue?