Results 1 to 6 of 6
  1. #1
    Community Member
    Join Date
    Apr 2013
    Posts
    5

    Default Any progress on reconnecting old forum display names with our accounts?

    So, simple really, I know that the new forums did not succeed for everyone in associating the old forum name with the proper account. Many of us selected new forum names. We've been told that the old names would be reconnected to our accounts.

    Anyone actually have this occur? How long does it take? When should we give up all hope?

  2. #2
    Community Member
    Join Date
    Apr 2013
    Posts
    14

    Default

    I gave up hope the day it happened lol.

  3. #3
    Community Member ~Grubbby's Avatar
    Join Date
    Apr 2013
    Posts
    15

    Default

    Just got this email from Turbine support an hour or so ago:

    "Greetings!

    We wanted to give you a status update regarding your forum account. Our web developers will be deploying a fix to correct your forum account within the next day or two. You do not need to take any action at this time, and once our deployment is complete we will send another email to confirm that we've completed the process. Thank you so much for your patience while we work to correct your account!

    Thank you,
    The Turbine Customer Service Team"
    The poster formerly known as TPICKRELL.... Hopefully will be again if Turbine support ever gets it straightened out. .. Grubby WF Shintao, Grubonon Human HAMP Shintao, GrubbyDark Halfling Ninja Spy, GrubbSmash Horc soon to be Henshin, GrubbyTrap Monk/Rogue/Fighter, Gralak Shirardi Sorc (soon to be PM Wiz again) and other Grubs... All on Khyber

  4. #4
    Scholar Of Adventure & Hero Missing_Minds's Avatar
    Join Date
    Jun 2006
    Location
    work....
    Posts
    30,354

    Default

    Quote Originally Posted by Royce View Post
    Anyone actually have this occur? How long does it take? When should we give up all hope?
    It took 2 weeks from sending in my ticket to get my "life" back.

  5. #5
    Community Member ~Phemt's Avatar
    Join Date
    Apr 2013
    Posts
    43

    Default

    Quote Originally Posted by Grubbby View Post
    Just got this email from Turbine support an hour or so ago:

    "Greetings!

    We wanted to give you a status update regarding your forum account. Our web developers will be deploying a fix to correct your forum account within the next day or two. You do not need to take any action at this time, and once our deployment is complete we will send another email to confirm that we've completed the process. Thank you so much for your patience while we work to correct your account!

    Thank you,
    The Turbine Customer Service Team"
    Looks like they are still trying to fix it...

  6. #6
    Community Member TheNameIwasntB4's Avatar
    Join Date
    Apr 2013
    Posts
    144

    Default Good News!!

    The same dev that worked on the robe/outfit fiasco is working on this one. What could possibly go wrong?

    One of my characters is still running around in the phantom outfit they did not give me. My inventory slot is still blank, but I ain't necked.
    April 2013 - Manager Meeting - New Forums, WOW!! We just had over 90% new players join!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload