Page 1 of 3 123 LastLast
Results 1 to 20 of 58
  1. #1
    Community Member Silex_Molior's Avatar
    Join Date
    Apr 2006
    Posts
    317

    Default 2 Minutes to log a character into game

    From the character selection screen, with the character selected, I press "Enter" to log that character into the world.

    1:30 seconds with the loading bar empty (black, no sign of blue at all)
    1:31 the first sliver of blue appears
    1:55 the bar is full, but then holds there
    2:02 world appears, character can move.

    This started happening a few updates ago, I wanna say 14 but it could be 13. I remember it coincided with Turbine announcing an update to their rendering engine. Whatever the new engine is, its horrible for loading. Same long lag times zoning into a new area (once area is entered, re-entry is faster).

  2. #2

    Default

    I thought this was going to be about the stutter-load that happens all too frequently. I'd put the occurance at ~30% of all loads, including cached loads where you exit to character screen and go back in AND when you close the client and re-start it:

    10 seconds from choosing your character until the world draws
    2 seconds for the second frame to draw
    2 seconds for the third frame to draw
    2 seconds for the fourth frame to draw
    ...2 minutes go buy, with 1 frame drawing every 2 seconds...
    Finally the world "wakes up" and is playable

    This probably is incredibly annoying when switching between alts for guild raids.

  3. #3
    Community Member Wanesa's Avatar
    Join Date
    Sep 2012
    Location
    Prague
    Posts
    527

    Default

    Try this "preloader"

    https://dl.dropbox.com/u/46772187/ddopreload.zip

    Use it to start game (it starts launcher). Min 2GB of memory is required.

    Small program preloads the most important file into cache, which speedups first phase of loading (where empty progress bar appear for very long time)

    This works with HDDs. Program is useless with SSDs

    Edit: Extract file into DDO main folder - the folder, where is ddoclient.exe and execute it from this folder.
    Last edited by Wanesa; 02-12-2013 at 07:05 PM.

  4. #4
    Community Member rest's Avatar
    Join Date
    May 2006
    Location
    Burque
    Posts
    5,602

    Default

    Quote Originally Posted by Wanesa View Post
    Try this "preloader"

    https://dl.dropbox.com/u/46772187/ddopreload.zip

    Use it to start game (it starts launcher). Min 2GB of memory is required.

    Small program preloads the most important file into cache, which speedups first phase of loading (where empty progress bar appear for very long time)

    This works with HDDs. Program is useless with SSDs

    Edit: Extract file into DDO main folder - the folder, where is ddoclient.exe and execute it from this folder.

    Somehow this seems shady to me.

  5. #5
    Community Member
    Join Date
    Oct 2009
    Location
    In a box.
    Posts
    2,268

    Default

    Quote Originally Posted by EllisDee37 View Post
    I thought this was going to be about the stutter-load that happens all too frequently. I'd put the occurance at ~30% of all loads, including cached loads where you exit to character screen and go back in AND when you close the client and re-start it:

    10 seconds from choosing your character until the world draws
    2 seconds for the second frame to draw
    2 seconds for the third frame to draw
    2 seconds for the fourth frame to draw
    ...2 minutes go buy, with 1 frame drawing every 2 seconds...
    Finally the world "wakes up" and is playable

    This probably is incredibly annoying when switching between alts for guild raids.
    This is what I see during festival events now, and was the standard loading MO on my old 2006 HP.

    What the OP described is what I've seen recently also (more or less since the ice games packed up for the winter). It happens on the first login of the day (I'd assume after a boot); logins after the initial one take 15 or 20 seconds. Far as I can recall, it's not always like that, but there are periods of the year when it occurs on a regular basis.

  6. #6

    Default

    Quote Originally Posted by Silex_Molior View Post
    From the character selection screen, with the character selected, I press "Enter" to log that character into the world.

    1:30 seconds with the loading bar empty (black, no sign of blue at all)
    1:31 the first sliver of blue appears
    1:55 the bar is full, but then holds there
    2:02 world appears, character can move.

    This started happening a few updates ago, I wanna say 14 but it could be 13. I remember it coincided with Turbine announcing an update to their rendering engine. Whatever the new engine is, its horrible for loading. Same long lag times zoning into a new area (once area is entered, re-entry is faster).
    when is the last time you defragged your hard drive?

    Last time you reinstalled the game?

    I run an SSD and generally am logged into game and moving in under 20 seconds. If I'm on my SHip, it takes a lot longer, but still under a minute.
    °º¤ø,¸¸,ø¤º°`°º¤ø,¸,ø¤°º¤ø,¸ ¸,ø¤º°`°º¤ø,¸A R C H A N G E L S °º¤ø,¸¸,ø¤º°`°º¤ø,¸,ø¤°º¤ø,¸ ¸,ø¤º°`°º¤ø,¸
    Thelanis

    Alandael ~ Allendale ~ iForged ~ Roba ~ Sylon ~ Pokah ~ Keyanu ~ Wreckoning
    Quote Originally Posted by Severlin View Post
    We don't envision starting players with Starter Gear and zero knowledge playing on Hard or Elite.
    Sev~

  7. #7
    Community Member brickwall's Avatar
    Join Date
    Nov 2006
    Location
    In Door's
    Posts
    453

    Default

    I suggest the use of diskeeper over time ddo game files become fragmented and scattered over traditional hard drives resulting in longer load times. diskeeper is and simple all in one set it and forget it solution to loss of performance from traditional hard drives.
    Vertabreaker On Steam
    Vertabreaker's Power Hungry Quest TR 29 Of 40
    Encourage Self Sufficiency
    Power Gamer - Meta Gamer Since 1985


  8. #8
    2015 DDO Players Council Seikojin's Avatar
    Join Date
    Feb 2006
    Location
    gamertown usa
    Posts
    6,522

    Default

    Every big update, I defrag the dat files. Helps quite a bit. Also remove any saved screenshots from time to time. It indexes that for naming.

  9. #9
    Community Member
    Join Date
    Aug 2010
    Location
    England
    Posts
    995

    Default

    Hello OP

    I used to have this problem - long load times especially on first alt log in.


    I cured it by buying SSD drives - now my times are around 15 seconds

    HTH

  10. #10
    Community Member Wendolyn's Avatar
    Join Date
    Feb 2010
    Posts
    60

    Default

    Quote Originally Posted by Seikojin View Post
    Every big update, I defrag the dat files. Helps quite a bit. Also remove any saved screenshots from time to time. It indexes that for naming.
    How do you defrag your dat files? I have read something about a defragger, but:

    a. It was old, and I seem to recall that Turbine said not to use it
    b. It was for LOTRO files

    Lately I've become more frustrated about longer load times, so I'm looking into options I have of shortening that (and I think buying a SSD is not an option my wife endorses )

  11. #11
    Community Member Mastikator's Avatar
    Join Date
    Sep 2009
    Location
    Thelanis
    Posts
    1,065

    Default

    Usually takes me 3 minutes to log on, 0% fragmentation.
    If I exit then it usually only takes 10-20 seconds to log on again until I shut down the computer.
    That which does not kill you gives you experience points.

    (Fighter->Fighter->Fighter->Monk->Monk->Barbarian->Paladin->Ranger)

  12. #12
    Community Member lethargos's Avatar
    Join Date
    Mar 2010
    Location
    gitmo nation reindeer
    Posts
    634

    Default

    Changed to ssd disk. Loading times are miniscule compared to old hard drive. Trust me, its your hard drive.
    - Kalevala of Khyber- Suomi Funland Perkele -

  13. #13
    Community Member Wanesa's Avatar
    Join Date
    Sep 2012
    Location
    Prague
    Posts
    527

    Default

    Quote Originally Posted by rest View Post
    Somehow this seems shady to me.
    I understand to your worries. You can trust me. Use Dependency Walker to ensure, that this tool doesn't have access to internet (nor winsock nor wininet reference) and also it doesn't refer any harmful function from WinAPI.

    It is really working. You will not need to replace your HDD with SSD. Try it.

  14. #14
    Community Member Silex_Molior's Avatar
    Join Date
    Apr 2006
    Posts
    317

    Default

    To be clear, it is not my harddrive.

    Not only do I defrag it once/week, but I reinstall DDO (ultimate Dat Defrag!) from scratch once/month.

    Lastly, its the same harddrive which loaded DDO in about 20 seconds... right up until DDO changed their rendering engine. Occam's Razor says that my harddrive did not just HAPPEN to suddenly slow down DDO (and only DDO, mind you, other MMOs are still the same speed they always were) at the same time Turbine updated the rendering engine of DDO.

    No, Occam's clearly indicates the problem is DDO, not my HD.

  15. #15
    Community Member
    Join Date
    Jan 2010
    Posts
    1,316

    Default

    Quote Originally Posted by EllisDee37 View Post
    I thought this was going to be about the stutter-load that happens all too frequently. I'd put the occurance at ~30% of all loads, including cached loads where you exit to character screen and go back in AND when you close the client and re-start it:

    10 seconds from choosing your character until the world draws
    2 seconds for the second frame to draw
    2 seconds for the third frame to draw
    2 seconds for the fourth frame to draw
    ...2 minutes go buy, with 1 frame drawing every 2 seconds...
    Finally the world "wakes up" and is playable

    This probably is incredibly annoying when switching between alts for guild raids.
    I get this periodically, and I use an SSD. It is a communication issue with the server. It seems to happen most, if not exclusively, when the first toon I load is in the crafting hall. After the toon *finally* loads in, that particular issue doesn't come back until the next time I log in. I would bet dollars to donuts, someone in that same instance is experiencing "crushing lag" as the server struggles to load my toon.

  16. #16

    Default

    When I log in after first booting up my computer, I get to the character select screen no problem. Trying to get an actual character in, it will sit at the loading screen (with and without the progress bar) for about 5 minutes, then it goes in-game where the connection bar is showing the red disconnect. After about a minute of that (if I don't kill the program manually), it crashes and I get a "Could not connect to server" error.

    After that, I go from the password window to being in-game in about 15-20 seconds.
    I am the 'Who' In the call "Who's there!?"
    I am the wind blowing through your hair.
    I am the shadow on the moon at night, filling your dreams to the brim with fright.

  17. #17
    Community Member
    Join Date
    Jan 2010
    Posts
    1,316

    Default

    Quote Originally Posted by Matuse View Post
    When I log in after first booting up my computer, I get to the character select screen no problem. Trying to get an actual character in, it will sit at the loading screen (with and without the progress bar) for about 5 minutes, then it goes in-game where the connection bar is showing the red disconnect. After about a minute of that (if I don't kill the program manually), it crashes and I get a "Could not connect to server" error.

    After that, I go from the password window to being in-game in about 15-20 seconds.
    I used to get exactly this problem 100% of the time as well. It only happens after you first boot Windows. I switched to an SSD drive and haven't seen it since. It would seem to be strongly tied to the incredibly long load time the client takes after a fresh boot of Windows. The server seems to be expecting a reply from the client within a certain amount of time and by the time the client gets around to responding, the server has given up on it and closed the connection. Since it loads more quickly the second time around everything works ok. It used to take me 7 minutes to start moving in game from the time I pushed the power button on the machine.
    Last edited by Katie_Seaglen; 02-13-2013 at 09:43 AM.

  18. #18

    Default

    Just for the record, I could very well be having these same slow load issues but I will never know, since the first time I run DDO in a session I always go smoke. The game is either ready to goo when I get back or (very rarely) red-icon dropping me.

  19. #19

    Default

    Quote Originally Posted by Wanesa View Post
    Try this "preloader"...
    You wouldn't happen to have or be able get the source for that would you?
    The newest computer can merely compound, at speed, the oldest problem in the relations between human beings, and in the end the communicator will be confronted with the old problem, of what to say and how to say it. - Edward R. Murrow (1964)

  20. #20

    Default

    Quote Originally Posted by Silex_Molior View Post
    To be clear, it is not my harddrive.

    Not only do I defrag it once/week, but I reinstall DDO (ultimate Dat Defrag!) from scratch once/month.

    Lastly, its the same harddrive which loaded DDO in about 20 seconds... right up until DDO changed their rendering engine. Occam's Razor says that my harddrive did not just HAPPEN to suddenly slow down DDO (and only DDO, mind you, other MMOs are still the same speed they always were) at the same time Turbine updated the rendering engine of DDO.

    No, Occam's clearly indicates the problem is DDO, not my HD.
    right after I Installed Win8, I had some driver issues.. I would Blue screen....

    I was able to reboot my machine, start DDO back up, and load bac into game in well under 2 minutes. People didnt even realize I crashed.... and I was on a cleric...

    Its something in your machine, or perhaps internet connection. Or maybe DDO has selective slow loading?
    °º¤ø,¸¸,ø¤º°`°º¤ø,¸,ø¤°º¤ø,¸ ¸,ø¤º°`°º¤ø,¸A R C H A N G E L S °º¤ø,¸¸,ø¤º°`°º¤ø,¸,ø¤°º¤ø,¸ ¸,ø¤º°`°º¤ø,¸
    Thelanis

    Alandael ~ Allendale ~ iForged ~ Roba ~ Sylon ~ Pokah ~ Keyanu ~ Wreckoning
    Quote Originally Posted by Severlin View Post
    We don't envision starting players with Starter Gear and zero knowledge playing on Hard or Elite.
    Sev~

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload