Results 1 to 18 of 18
  1. #1
    Community Member Zonixx's Avatar
    Join Date
    Jan 2012
    Posts
    696

    Default Anyone get pyLOTRO to work after U16?

    Hey I have updated everything and while the turbine launcher seems to work fine, for some reason when I try loading up DDO using pyLOTRO it says I do not have the current patch version installed.

    Anyone find a fix to this?

    EDIT: Found a fix.

    Copied my entire DDO folder to my harddrive, re-installed the update and set pyLOTRO to the copy. Then I deleted my original.

    This does not seem like it should be the only solution, but it worked.
    Last edited by Zonixx; 11-12-2012 at 04:16 PM.
    If you are reading this, that probably means I am broadcasting live @ http://www.twitch.tv/ZonixxTV

  2. #2
    Community Member gphysalis's Avatar
    Join Date
    Jun 2010
    Posts
    893

    Default

    I have this problem too,

    Now I can't play DDO
    Quote Originally Posted by Eladrin View Post
    Grease is the only party buff
    Quote Originally Posted by MajMalphunktion View Post
    talk about your exploits
    Quote Originally Posted by Memnir View Post
    DDO is not PnP. This is by design

  3. #3
    Community Member Zonixx's Avatar
    Join Date
    Jan 2012
    Posts
    696

    Default

    Found a fix, updated the OP
    If you are reading this, that probably means I am broadcasting live @ http://www.twitch.tv/ZonixxTV

  4. #4
    Community Member Eilyen's Avatar
    Join Date
    May 2009
    Posts
    90

    Default

    The first time you patched post update 16 it attempted to update patchclient.dll and failed badly.

    There should be a backup copy inside your DDO folder/Backup, make a copy in the main folder, name it something other than patchclient.dll then start pyLOTRO. Tools -> options, then check "advanced options" type your new dll name, then patch. It should correctly update to the new patchclient.dll

    After that you should be able to undo the advance options and use the normal dll.

  5. #5
    Community Member Zonixx's Avatar
    Join Date
    Jan 2012
    Posts
    696

    Default

    Quote Originally Posted by Eilyen View Post
    The first time you patched post update 16 it attempted to update patchclient.dll and failed badly.

    There should be a backup copy inside your DDO folder/Backup, make a copy in the main folder, name it something other than patchclient.dll then start pyLOTRO. Tools -> options, then check "advanced options" type your new dll name, then patch. It should correctly update to the new patchclient.dll

    After that you should be able to undo the advance options and use the normal dll.
    ok thank you, this would have been much easier then copying/reinstalling
    If you are reading this, that probably means I am broadcasting live @ http://www.twitch.tv/ZonixxTV

  6. #6
    Community Member Blayster's Avatar
    Join Date
    May 2012
    Posts
    155

    Default

    Quote Originally Posted by Eilyen View Post
    The first time you patched post update 16 it attempted to update patchclient.dll and failed badly.

    There should be a backup copy inside your DDO folder/Backup, make a copy in the main folder, name it something other than patchclient.dll then start pyLOTRO. Tools -> options, then check "advanced options" type your new dll name, then patch. It should correctly update to the new patchclient.dll

    After that you should be able to undo the advance options and use the normal dll.
    Oh, this solution is a bit fuzzy for me, because I use lotrolauncher rather than pylotro (there is no advanced options for choosing the patchclient.dll, I think it uses the default one). Any idea on what to do in this case? (I do have a backup folder).

  7. #7
    Community Member Relenthe's Avatar
    Join Date
    Sep 2006
    Posts
    703

    Default

    Quote Originally Posted by Eilyen View Post
    The first time you patched post update 16 it attempted to update patchclient.dll and failed badly.

    There should be a backup copy inside your DDO folder/Backup, make a copy in the main folder, name it something other than patchclient.dll then start pyLOTRO. Tools -> options, then check "advanced options" type your new dll name, then patch. It should correctly update to the new patchclient.dll

    After that you should be able to undo the advance options and use the normal dll.
    What if I already patched the game under the broken .dll? I tried what you said and patched it, but it said there was 0 bytes to download then it finished, and it is still broken
    Exelin etc, exception Estelix of Elite Raiders, Khyber
    Quote Originally Posted by Eladrin View Post
    I often word things in ways that cause the most speculation and panic, because I'm capricious and mean.

  8. #8
    Community Member
    Join Date
    Oct 2009
    Posts
    914

    Default

    On a few of the updates I''ve had to spam the "patch game" option. This time as well. I think I got a few "FAILED" messages as well, typically my client simply gives up.

  9. #9
    Community Member Draggoon64's Avatar
    Join Date
    Aug 2010
    Location
    Ontario Canada
    Posts
    41

    Default dndclient failure after update 16

    I having been experiencing the same issue today as well. I am running Fedora 17 Wine 1.5.16, updated as of 2pm today. I am right now doing a reinstall after trying a couple of different patchclient.dll versions i had backed up.
    We'll see tho

  10. #10
    Community Member
    Join Date
    Dec 2009
    Location
    Rio de Janeiro, Brasil
    Posts
    2,547

    Default

    It is working here, but I had to grab the new patchclient dll from a guildie.
    Kmnh * Kmn * Kmm * Knn * Knm

    Leader of Templar

  11. #11
    Community Member Draggoon64's Avatar
    Join Date
    Aug 2010
    Location
    Ontario Canada
    Posts
    41

    Default Any fix yet???

    I am still getting a error with dndclient.exe

  12. #12
    Scholar Of Adventure & Hero Missing_Minds's Avatar
    Join Date
    Jun 2006
    Location
    work....
    Posts
    30,170

    Default

    Quote Originally Posted by Draggoon64 View Post
    I am still getting a error with dndclient.exe
    Dragon *and others* you may find more information over in the lotro boards. I don't know. I use Win7 so... I'm of no use to you. (big surprise there, huh.)

  13. #13
    Community Member Blayster's Avatar
    Join Date
    May 2012
    Posts
    155

    Default

    Quote Originally Posted by Kmnh View Post
    It is working here, but I had to grab the new patchclient dll from a guildie.
    I also got the patchclient dll from a guildie, but it is not working still. I put it in the directory with the same name and it just fails in the same way. I use lotrolauncher not pylotro so I cannot point to a different patchclient.dll

    Does anyone have any idea?

    EDIT#1: I uploaded the traceback of the error here: http://pastebin.com/3rkmQZxF
    Is this the error you guys are seeing also or am I in more trouble than you guys?
    Last edited by Blayster; 11-15-2012 at 01:36 PM.

  14. #14
    Community Member Relenthe's Avatar
    Join Date
    Sep 2006
    Posts
    703

    Default

    Quote Originally Posted by Blayster View Post
    I also got the patchclient dll from a guildie, but it is not working still. I put it in the directory with the same name and it just fails in the same way. I use lotrolauncher not pylotro so I cannot point to a different patchclient.dll

    Does anyone have any idea?

    EDIT#1: I uploaded the traceback of the error here: http://pastebin.com/3rkmQZxF
    Is this the error you guys are seeing also or am I in more trouble than you guys?
    That's basically the same error I am receiving, so in the same boat
    Exelin etc, exception Estelix of Elite Raiders, Khyber
    Quote Originally Posted by Eladrin View Post
    I often word things in ways that cause the most speculation and panic, because I'm capricious and mean.

  15. #15
    Community Member Draggoon64's Avatar
    Join Date
    Aug 2010
    Location
    Ontario Canada
    Posts
    41

    Default

    Quote Originally Posted by Draggoon64 View Post
    I am still getting a error with dndclient.exe
    Still getting the dndclient.exe error when trying to launch DDO with PyLotRO

    I have so far yum -y remove wine* removed the .wine/ from my Home drive and reinstalled Wine 1.5.16
    Did a Clean install of DDO high res. and then PyLotRO applied and patchclient and patched it
    Which is still running so we'll see what happens in a bit.

  16. #16
    Community Member
    Join Date
    Nov 2009
    Posts
    151

    Default

    Quote Originally Posted by Draggoon64 View Post
    Still getting the dndclient.exe error when trying to launch DDO with PyLotRO

    I have so far yum -y remove wine* removed the .wine/ from my Home drive and reinstalled Wine 1.5.16
    Did a Clean install of DDO high res. and then PyLotRO applied and patchclient and patched it
    Which is still running so we'll see what happens in a bit.
    I should see about getting a patched copy of the patchclient.dll from someone and see if that helps or not.

  17. #17
    Community Member Draggoon64's Avatar
    Join Date
    Aug 2010
    Location
    Ontario Canada
    Posts
    41

    Default dndclient Log

    000000000.000: LookForFile trying cwd
    000000000.000: Is_File_Here found 'client_general.dat' in 'C:/Program Files/Turbine/DDO Unlimited'
    000000000.000:

    DiskCon::InitFile:
    datfile "client_general.dat" stamped with datpack versions eng:112, game:3,
    executable supporting datpack versions eng:-1, game: -1.

    000000000.000:

    DiskCon::InitFile:
    datfile "client_highres.dat" stamped with datpack versions eng:112, game:3,
    executable supporting datpack versions eng:-1, game: -1.

    000000000.000:

    DiskCon::InitFile:
    datfile "client_gamelogic.dat" stamped with datpack versions eng:112, game:3,
    executable supporting datpack versions eng:-1, game: -1.

    000000000.000:

    DiskCon::InitFile:
    datfile "client_anim.dat" stamped with datpack versions eng:112, game:3,
    executable supporting datpack versions eng:-1, game: -1.

    000000000.000:

    DiskCon::InitFile:
    datfile "client_mesh.dat" stamped with datpack versions eng:112, game:3,
    executable supporting datpack versions eng:-1, game: -1.

    000000000.000:

    DiskCon::InitFile:
    datfile "client_sound.dat" stamped with datpack versions eng:112, game:3,
    executable supporting datpack versions eng:-1, game: -1.

    000000000.000:

    DiskCon::InitFile:
    datfile "client_surface.dat" stamped with datpack versions eng:112, game:3,
    executable supporting datpack versions eng:-1, game: -1.

    000000000.000:

    DiskCon::InitFile:
    datfile "client_cell_1.dat" stamped with datpack versions eng:112, game:0,
    executable supporting datpack versions eng:-1, game: -1.

    000000000.000:

    DiskCon::InitFile:
    datfile "client_map_1.dat" stamped with datpack versions eng:112, game:0,
    executable supporting datpack versions eng:-1, game: -1.

    000000000.000:

    DiskCon::InitFile:
    datfile "client_local_English.dat" stamped with datpack versions eng:112, game:3,
    executable supporting datpack versions eng:-1, game: -1.


    This is the log file from when dndcleint fails

  18. #18
    Community Member Draggoon64's Avatar
    Join Date
    Aug 2010
    Location
    Ontario Canada
    Posts
    41

    Default Patch

    Quote Originally Posted by MrElusiveness View Post
    I should see about getting a patched copy of the patchclient.dll from someone and see if that helps or not.
    If you have been able to get DDO work ON linux with Wine and a NEW patchclient... PLEASE send it to me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload