Results 1 to 5 of 5
  1. #1
    Community Member mr.stevens's Avatar
    Join Date
    Aug 2010

    Default Newly downloaded Lamannia preview stuck at connect

    I'm new to the Lamannia server and have recently downloaded the program. When I start it up it just sits there 'waiting' for a connection.

    By which I mean that the 'Game Update Progress' gets stuck on the first item 'connect' with the status 'waiting'.

    Is there no connection to be had if this occurs (I would expect an error message if this was the case) or is there something wrong with the program?

  2. #2


    Yep, just happened to me.

    Reinstalled, used 'turbine invoker' to load it. after a couple of tries it worked.

    Waste of a download as it reupdated itself was the pain.

  3. #3
    Community Member DrakeFury's Avatar
    Join Date
    Jul 2010


    Yep, same problem here. Reinstalled it twice, started turbine invoker and every other app in installed folder and no luck. After client updated it is stuck on connect.

  4. #4


    Quick add to the above.

    I tried to start up the llamaland shortcut from my desktop, 3 times with no luck.

    Worked first time from the turbineinvoker execuable directly from the install folder.

    Hope it helps.

  5. #5
    Community Member mr.stevens's Avatar
    Join Date
    Aug 2010

    Smile Success!

    Thanks for the replies. Glad it's not just me.

    I tried both the 'TurbineLauncher' and the 'TurbineInvoker' before I posted originally. I managed to get a few update files downloaded and then a required restart. Then I had the above problem with the 'connect'.

    Several hours later now and I've just used the 'dndlauncher'.'s started to download aprox 11,000 update files. (typing in real so time let's see if I can get connected!)

    This is gonna take a while...tum te tum...30% complete...46% complete...scratch head...make other forums...73%...95%...98%...100%...get worried because it says last world played Thelanis...uncheck box to enter last played world...choice of LAMANNIA in available on PLAY...agree to T&C's...mild celabration as I'm in...but have no characters yet...QUIT!

    So it works. I didn't have to re-install the files. Do not know why it didn't work straight away. If this happens to you just come back to it later and try again. Thanks for the input, rep for you both.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.