Results 1 to 3 of 3
  1. #1
    Community Member decease's Avatar
    Join Date
    Jul 2011

    Default unable to buy tp

    got message "We are sorry, we were unable to process this transaction because this account has been suspended. Please contact customer support."

    have bought ddo point many times before, also pre order upcoming expansion not long ago. some how it won't let me do it today..

    p.s. read about it on forum, could it be cause by the fact am currently traveling outside American? don't think i could make back before this sale end though.. hope thats not the issue

    problem fixed.. it is the location ip issue.. i got a friend to buy it for me and it work. btw.. you guys really should fix this issue.. i mean most player don't live in american.. plus many people like to travel around..
    Last edited by decease; 04-01-2012 at 11:33 AM.

  2. #2
    Community Member
    Join Date
    Feb 2011


    I am getting the same error message. I was able to buy a points pack, but when I went to buy another it errored out. I would like to not miss the timeframe to be able to get the bonus points, but it's not working. I called my CC company and they said they haven't gotten any requests which means the problem is on Turbine's side.

  3. #3
    Customer Service Representative
    Join Date
    Dec 2010


    decease, glad you were able to resolve the issue

    Amalphia, if after talking to the bank you are still not able to purchase Turbine Points, you can contact the Account Management team directly. They will be happy to help!
    DDO Support Page & Knowledge Base
    To request support from a Customer Service Agent, simply click on "Submit a Ticket"
    English Account/Store Support is available from 2:00 pm to 6:00 pm, Monday through Friday (GMT -5). 855-WBGAMES (855-924-2637)

    Contact us on Twitter @DDOUnlimited

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.