Results 1 to 4 of 4
  1. #1
    Community Member
    Join Date
    Mar 2006
    Posts
    1,221

    Default Any problems with account reactivation currently?

    A friend of mine reactivated his account about 12 hrs ago and it still will not allow him to login.

    myaccount.turbine.com says active but the forums and game login still tell him it is inactive.

    I tried a search on the forums and knowledge base but it didn't mention anything...

  2. #2
    Community Member
    Join Date
    Mar 2006
    Posts
    1,221

    Default

    deactivating and reactivating again solved the issue...

    Hopefully it doesn't charge the cc twice

  3. #3

    Default same here

    Two accounts, waited thirty minutes with no luck even though showing active at their website. Emails verified the time with no service even though I had paid. Cancelling and resuming solved the problem.
    I agree there is more then one way to spot a trap but my way doesn't cost you your hit points..............

  4. #4
    Customer Service Representative Victorie's Avatar
    Join Date
    Aug 2008
    Posts
    2,207

    Default

    There is a known issue regarding reinstatement from the billing website. We're working on fixing it. In the meantime, if resuming, canceling and resuming again works, then go with it. It won't charge the card twice - the system is actually set up to prevent that.
    DDO Support Page & Knowledge Base
    To request support from a Customer Service Agent, simply click on "Submit a Ticket"
    English Account/Store Support is available Monday through Friday from 2:00 pm to 6:00 pm (GMT -5). 855-WBGAMES (855-924-2637)

    Contact us on Twitter @DDOUnlimited

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload