Results 1 to 17 of 17
  1. #1
    Community Member Thame's Avatar
    Join Date
    Mar 2006
    Location
    Phoenix AZ
    Posts
    1,157

    Default dont buy slayer pots

    The timers are clicking down in quests also. Save your points/money until its fixed. FYI

  2. #2
    Community Member Grosbeak07's Avatar
    Join Date
    Oct 2007
    Location
    Thelanis
    Posts
    7,590

    Default

    Quote Originally Posted by Thame View Post
    The timers are clicking down in quests also. Save your points/money until its fixed. FYI
    I've been using the 200% slayers all week and have not seem them tick down at all, except in slayer areas.
    Magical Rings are well... magical. - Gandalf

  3. #3
    Community Member Nestroy's Avatar
    Join Date
    Jul 2011
    Location
    Europe, and proud of it
    Posts
    2,829

    Default

    Quote Originally Posted by Thame View Post
    The timers are clicking down in quests also. Save your points/money until its fixed. FYI
    This has to be new. Please @OP help your community and the devs here: Quests, server?

    Yesterday the slayer pots definitively were OK. even the cookie ones I traded for my coinage.

  4. #4
    Community Member Thame's Avatar
    Join Date
    Mar 2006
    Location
    Phoenix AZ
    Posts
    1,157

    Default

    all quests thelanis server

  5. #5
    Community Member
    Join Date
    Nov 2007
    Posts
    82

    Default

    My Guildies and I have noticed that the LoB cookie version of the slayer boost does count down in quests, but the potion variety seem to be working fine.

  6. #6
    Euro-Founder and Keeper Refugee Dexraven's Avatar
    Join Date
    Apr 2013
    Posts
    229

    Default

    mine worked fine 2 days ago on T-land
    Leader of the Unearthed Arcana

  7. #7
    Community Member Thame's Avatar
    Join Date
    Mar 2006
    Location
    Phoenix AZ
    Posts
    1,157

    Default

    wasnt a cookie was a store bought pot. a guildie had the same problem

  8. #8
    Community Member bartharok's Avatar
    Join Date
    Dec 2009
    Location
    Far beyond the ravens gate
    Posts
    5,509

    Default

    I have had this happen at times. No pattern as far as ive noticed.
    Dystopia = utopia achieved

  9. #9
    Community Member Nestroy's Avatar
    Join Date
    Jul 2011
    Location
    Europe, and proud of it
    Posts
    2,829

    Default

    At least on Wayfinder, I can assure you, the pots do just work fine.

  10. #10
    Community Member Zzevel's Avatar
    Join Date
    Dec 2008
    Location
    Madison, WI
    Posts
    783

    Default

    2 days ago i pulled some old slayer pots off a bank toon (trying tio finish my lv 20...) and noticed the pot timer was ticking down while standing on my guildship. As I haven't used a slayer pot in over a year, i figured they changed the timer with the other changes.... Sarlona

  11. #11
    Hero LOOON375's Avatar
    Join Date
    Dec 2009
    Location
    Argo
    Posts
    1,692

    Default

    They work fine for me on Argo.
    The Fockers of Argo
    Fuglymofo; LOOON; Hobaggin; Fuglyrobo; Buttscracher; Whoaa

  12. #12
    Community Member Atremus's Avatar
    Join Date
    Oct 2010
    Location
    Aegis
    Posts
    1,269

    Default

    Working fine as of last night on Orien in Storm Horns / Break in the Ice
    Characters: Celemia / Tukson / Thau (Broken link) / Atremus

    “A pessimist is one who feels bad when he feels good for fear he'll feel worse when he feels better.”

  13. #13
    Community Member
    Join Date
    Oct 2009
    Posts
    45

    Default

    This has happened to me (on ghallanda) It may or may not have have been an old pot or a random dice roll drop. Either way not a constant problem, as other pots have worked fine.

  14. #14
    Uber Completionist
    Join Date
    Jun 2013
    Location
    Quebec, Canada
    Posts
    796

    Default

    Quote Originally Posted by Atremus View Post
    Working fine as of last night on Orien in Storm Horns / Break in the Ice
    Idem... oh wait, I was in your group

  15. #15
    Community Member
    Join Date
    Apr 2011
    Posts
    5,380

    Default

    They are working fine for me although I lose the usual few seconds every time I teleport. I just live with that.
    CC Casting Druid: https://www.ddo.com/forums/showthrea...C-Summer-Build
    Shiradi Wiz Plan for 1st Lifers: https://www.ddo.com/forums/showthrea...r-First-Lifers
    U25 Patch 1 Dex Halfling Assassin Build: https://www.ddo.com/forums/showthrea...x-Assassin-1-0
    Warlock DC Caster: https://www.ddo.com/forums/showthrea...ld-Blast-Build

    Several characters on Sarlona all starting with "Rand" in the Guild "Guardians of House Cannith". My main four characters are Randowl (18 rogue 2 artificer mechanic - hope to go back to DC casting some day), Randslar (Bard 14 / Fighter 4 / Rogue 2 Swashbuckler), Randek (Druid CC Caster 17/Fvs 3) and Randomall (Rogue 20 assassin).

  16. #16
    The Hatchery
    2014 DDO Players Council
    Dandonk's Avatar
    Join Date
    Dec 2009
    Location
    Denmark
    Posts
    5,278

    Default

    They have worked fine for me so far.
    It's definitely an N-word.

  17. #17
    Community Member
    Join Date
    Sep 2009
    Posts
    58

    Default

    Quote Originally Posted by Thame View Post
    The timers are clicking down in quests also. Save your points/money until its fixed. FYI
    I had that problem last week.
    Was a very sad panda until I left the adventure I was in.
    The pot reset and all was well with the world.
    I am thirsty in the desert with an empty cup.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload