Results 1 to 5 of 5
  1. #1
    Community Member
    Join Date
    Nov 2007
    Posts
    2

    Default Account does not exist

    I just made a trial account at ddo.com and followed the instructions, and the account is active. I go to the game, it's fully patched. I try to log in... It does "retrying 1 of 5..." all the way to 5, and then it says it's invalid. I've triple checked that my password and username are correct, and I've made sure my capslock wasn't on (I've tried it with capslock on as well), and still no go.

    Can anyone tell me what I've done wrong?

  2. #2
    Community Member
    Join Date
    Nov 2007
    Posts
    2

    Default

    Alright, I made a COG account, and I tried logging in with that, and it says I have no active subscription. I tried using a trial key to activate DDO, but it said that the code was invalid. Ideas?

  3. #3
    Community Member GHOSTRYDER's Avatar
    Join Date
    Mar 2006
    Posts
    1,048

    Default

    maybe try logging in with the account name and password you created at myaccount.turbine.com? it should show you the status of your subscription there

  4. #4
    Developer Yeti's Avatar
    Join Date
    Feb 2006
    Posts
    356

    Default

    COG accounts are used for the European version of the game. If you are creating an account on a Codemasters site, you will need the European client in order to login. This is probably why you are getting the error, you have the North American Client and a European Account.

    You will need a North American account with the North American client or vice versa, they must match.

  5. #5
    Community Member
    Join Date
    Dec 2007
    Posts
    1

    Default

    If it is mixed up then how do you fix the problem with out re downloading the client? I am having the same problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload