PDA

View Full Version : Mac 64 bit update from Sev



Tricosene
04-26-2018, 11:25 PM
In case you missed it:
https://www.ddo.com/forums/showthread.php/496018-Still-no-answer-from-devs-to-a-Mac-issue


On the Mac side the client is already 64 bit; we *will* need to update the launcher and the patch DLLs though.

Sev~

Happy gaming!

jwelch
05-16-2018, 08:36 PM
In case you missed it:
https://www.ddo.com/forums/showthread.php/496018-Still-no-answer-from-devs-to-a-Mac-issue



Happy gaming!

current launcher and dndclient app are 32-bit as far as the OS is concerned.

Kaytis
05-18-2018, 02:57 PM
current launcher and dndclient app are 32-bit as far as the OS is concerned.



$ lipo -info /Applications/DNDLauncher.app/Contents/Resources/dndclient.app/Contents/MacOS/dndclient
Non-fat file: /Applications/DNDLauncher.app/Contents/Resources/dndclient.app/Contents/MacOS/dndclient is architecture: i386
.
.
.


Yes. The client is 32-bit only -along with all the accompanying libraries. Hopefully there is an internal 64-bit build working somewhere.

Tricosene
06-06-2018, 02:11 PM
SSG has some respite from this issue. The next version of Mac System Software, Mojave or 10.14, will support 32 bit applications. However, Mojave will be the last version to support 32 bit applications.

MacRumors article on Mojave and 32 bit applications. (https://www.macrumors.com/2018/06/05/mojave-last-macos-release-to-support-32-bit-apps/)

Don't forget to check on any other older applications you are using to find out if they are 32 bit only.

jwelch
06-07-2018, 04:25 PM
SSG has some respite from this issue. The next version of Mac System Software, Mojave or 10.14, will support 32 bit applications. However, Mojave will be the last version to support 32 bit applications.

MacRumors article on Mojave and 32 bit applications. (https://www.macrumors.com/2018/06/05/mojave-last-macos-release-to-support-32-bit-apps/)

Don't forget to check on any other older applications you are using to find out if they are 32 bit only.


I'd not make a lot of assumptions about what "support" truly means. Not that SSG should be lazy about it, but even though Carbon Apps haven't been "supported" for many years now, there's still a lot of Carbon APIs in the OS. I'd go with anything user-facing though, so while some background stuff may get a respite, AppKit will probably be 64-bit only. Depends on the level of user feedback Apple gets about things.

Tricosene
06-10-2018, 10:52 AM
I'd not make a lot of assumptions about what "support" truly means. Not that SSG should be lazy about it, but even though Carbon Apps haven't been "supported" for many years now, there's still a lot of Carbon APIs in the OS. I'd go with anything user-facing though, so while some background stuff may get a respite, AppKit will probably be 64-bit only. Depends on the level of user feedback Apple gets about things.

Well that's far more technical than I can understand.

I'm confused as to what you mean by making assumptions about "support." The article states - of course things might change etc - that Apple is putting a new warning in place when you start a 32 bit app, telling you that this app will not run in the next version of MacOS. It sounds as if nothing is changing in Mojave to compromise 32 bit apps functionality. Have you read otherwise?

Kaytis
06-11-2018, 11:32 AM
Well that's far more technical than I can understand.

I'm confused as to what you mean by making assumptions about "support." The article states - of course things might change etc - that Apple is putting a new warning in place when you start a 32 bit app, telling you that this app will not run in the next version of MacOS. It sounds as if nothing is changing in Mojave to compromise 32 bit apps functionality. Have you read otherwise?

For what it's worth, Apple has announced that QuickTime (which is 32-bit only) will be removed from macOS *next* year, i.e. not with Mojave (AKA macOS 10.14), but with whatever comes after that in late 2019. Speaking as someone who has worked with QuickTime since it's introduction in 1990, if it is supported in 10.14, then pretty much anything that is supported today will continue to work in Mojave. QuickTime is very old and very very crusty.