PDA

View Full Version : post U34 left mouse-klick bug



SamaelBael
02-02-2017, 04:07 PM
After updating DDo today some of the keybindings were changed and my left mouse-button requires double tapping for everything. Dropdown menus can be opened but not chosen from. The right mouse button works fine and every possible selection I am able to do with either of them requires only the single button push on the right.

I am at a loss on what to do. I exhausted previous threads, asked in Discord and did the following:
* changed the keybinding of the left mouse button a few times
*restarted client/ computer
*updated mouse driver
*replugged mouse

Has anyone encountered this problem?

I'm using OS 10.11.6 with a RAT 7 mouse.

edit:
I can't even drag'n drop weapons from the inventory. 1st klick does nothing, second equips the items. Holding the button down to drag the item has the same effect as just clicking on it.

Kaytis
02-02-2017, 11:17 PM
After updating DDo today some of the keybindings were changed and my left mouse-button requires double tapping for everything. Dropdown menus can be opened but not chosen from. The right mouse button works fine and every possible selection I am able to do with either of them requires only the single button push on the right.

I am at a loss on what to do. I exhausted previous threads, asked in Discord and did the following:
* changed the keybinding of the left mouse button a few times
*restarted client/ computer
*updated mouse driver
*replugged mouse

Has anyone encountered this problem?

I'm using OS 10.11.6 with a RAT 7 mouse.

edit:
I can't even drag'n drop weapons from the inventory. 1st klick does nothing, second equips the items. Holding the button down to drag the item has the same effect as just clicking on it.

When I loaded up the Lamannia client right before the release, all my mouse and key settings were extremely messed up. For example the left and right button had reversed roles. I went to the Key Mapping options and restored the default settings (which I use anyway) and it fixed everything up. Maybe try that?

SamaelBael
02-03-2017, 03:02 AM
... tyvm, restoring default really worked!

Now i just have to change everything back to the setting I'm used to without breaking anything^^

kbaskins
02-03-2017, 06:24 PM
... tyvm, restoring default really worked!

Now i just have to change everything back to the setting I'm used to without breaking anything^^

I had the same problem, so after finally figuring out how to fix it I thought I'd come here to post the solution, and you guys beat me to it! LOL'

I found that after I reset my keymapping to default, before I switched a key to a new binding I had to go clear an old one. For instance, I turned the "r" key off "run" a long time ago (due to an unfortunate tendency to inadvertently run off cliffs and such), and instead use it to "target" instead of "tab". After I reset my keymapping to default, I had to go clear the "run" key before I changed the "target" key to "r", otherwise, everything got mixed up again. Does that explanation make any sense? It does in my head, but I'm not sure anyone else will understand what I'm babbling about.

I noticed there was a new keymapping button for "Reaper Enhancements", so maybe that's what threw off the rest of the Mac keymapping prefs file. Whatever it was, it's fixable and that's all I care about. :-)

BTW, using MacOS 10.12.3 Sierra.

Kindoki
05-11-2018, 06:00 PM
Left Mouse button still a problem. I had never experienced it prior to now. I started playing DDO again after a long absence, just before U38 came out. I had been using a Logitech 5500 keyboard with zero issue up until last week, when I bought a new Apple Magic Keyboard with 9 pin. As soon as I started using that, my function keys stopped working to select party members. Today I went into key mapping to reset that. The F1 key was second option for mapping and the first option said "Modifier+Unknown". After trying to clear and set F1, my mouse key immediately stopped working. I could double click on a few things, but I couldn't close windows, couldn't scroll, etc. I couldn't log out of the game, and had to alt-tab and hard close. After trying a couple of different things in game, I opened the game and was able to double click the little default option under key mapping from the character screen, rather than in game (where it didn't work at all). That seemed to fix the mouse issue. I was then able to airdrop my ddo.keymap from my MacBook to my Mac Mini to replace the default one. That returned all of my shortcuts back to the way they were, with the exception of my function keys not working again, and the same odd notation under shortcut 1 for 'select yourself'. Actually a number of shortcuts now say unknown, but they all seem to work with the exception of the function keys. I then tried to remap the F1 button to select myself again. It allowed me to clear all the keys, including the weird "Modifier+Unknown" in shortcut 1. It allowed me to click on 'select myself', but when the warning message about hitting the next key to choose blah, blah, blah, came up and I hit F1, nothing happened. I then tried shift F1 and only the shift showed up. I tried it again and the whole thing went back to requiring double clicks for some things, and not working for most. Alt-Tab, hard close, airdrop ddo.keymap again. I also tried options other than F1. F3, as is the function of F3 on the keyboard, tiled my open windows, including DDO. I know that in Steam, with Total War, I had to disable the function key's, well, functions. Tried that here too. You can find this in your system preferences/keyboard/use F1 as standard function keys. That box should be checked. With that checked, all my function keys worked normally to select my party members, no further problems.