PDA

View Full Version : Voice Capture and Playback options greyed out



Zauberer_Zuba
07-28-2016, 07:28 PM
Hello, I am using a Mac and open the game client through Steam. I also have a fully functioning usb headset that I use all the time for other games and systems.

I cannot use voice chat (hear or talk) in-game. When I get to the bottom options in the audio interface, the Voice Playback and Capture Device options are greyed out and cannot be clicked on. I have not gained any ground trying different things. How can I get the game to recognize my microphone and let me even HEAR other players speaking?

Valamar
07-30-2016, 11:14 PM
Hello, I am using a Mac and open the game client through Steam. I also have a fully functioning usb headset that I use all the time for other games and systems.

I cannot use voice chat (hear or talk) in-game. When I get to the bottom options in the audio interface, the Voice Playback and Capture Device options are greyed out and cannot be clicked on. I have not gained any ground trying different things. How can I get the game to recognize my microphone and let me even HEAR other players speaking?
On the Mac check your settings in "System Preferences/Sound." -- both output and input.
You will have to manually switch OSX to use your headset.

Another tool which can be useful is "Applications/Utilities - Audio MIDI Seetup.app

The other thing which is true -- set up your Mac to first use your headset -- THEN launch DDO (or LOTRO for that matter).
The basic issue is that the internal client in both DDO and LOTRO never was very good.
My Guild/Kin has always used first Ventrillo and now Mumble because of the problems with the in-game audio.

Zauberer_Zuba
07-31-2016, 05:34 PM
On the Mac check your settings in "System Preferences/Sound." -- both output and input.
You will have to manually switch OSX to use your headset.

Another tool which can be useful is "Applications/Utilities - Audio MIDI Seetup.app

The other thing which is true -- set up your Mac to first use your headset -- THEN launch DDO (or LOTRO for that matter).
The basic issue is that the internal client in both DDO and LOTRO never was very good.
My Guild/Kin has always used first Ventrillo and now Mumble because of the problems with the in-game audio.

Thanks for your response. To clarify: I can hear game sounds through the headset, just not player voices. The settings in system preferences and the audio midi setup both have the usb headset fully functioning and with normal settings. I guess I will switch the Hz from 44100 to 48000 and see if that does anything? That really seems to be about the only thing I can really change.

[I tried changing the Hz levels and from stereo to multi channel and a couple other seemingly bizarre things to no avail. The headset works like a charm but DDO is getting it's panties in a twist trying to let me use it. I've gotten relatively familiar with all the audio settings now and the Mic test just wont work. I don't understand why I can hear game sound but not voice though.]

The most bizarre part of this to me is that I have steam functioning in the background of the game (shift tabbing opens up the in-game steam interface) where I can open up a text app with my brother and use voice calling through steam in the background of DDO, but within DDO itself, the whole voice scheme is shut off without the ability to toggle. There must be some hidden obstruction in all the settings, yet it's so close.

dontmater
07-31-2016, 06:12 PM
Im not a mac guy but on windows. sometimes i have to set audio at the character select screen for it to all to work right.
hope it helps

PermaBanned
02-28-2017, 05:53 PM
I seem to be having the same issue as the OP. All was good until I downloaded the last game patch, then my USB headset was no longer an option for Voice Playback or Capture (the drop down boxes are greyed out and locked on to "Line Out" for playback & "Built in..." for capture) even though Logitech USB is still selected for Game Sound playback. The OS is set to Logitech USB, and was before launching the client.

Things I tried:
Trashed the User Preferences file & relaunched DDO.
Various check boxes in the Audio UI.
(That's about it, not exactly tech savvy here)

Running the DDO Mac client natively (not via Steam) on OSX Lion. Any help appreciated - especially if it doesn't involve an un- & re-instal of DDO ;)

Tscheuss
02-28-2017, 06:36 PM
When my last headset failed, I replaced it with a USB headset. I had such trouble getting it to work with DDO. My fix was to take the USB headset back to the store and get one with conventional connectors. It has worked fine for years. :)

eurogeek
03-18-2017, 11:05 AM
...All was good until I downloaded the last game patch, then my USB headset was no longer an option for Voice Playback or Capture (the drop down boxes are greyed out and locked on to "Line Out" for playback & "Built in..." for capture) even though Logitech USB is still selected for Game Sound playback. The OS is set to Logitech USB, and was before launching the client.

Things I tried:
Trashed the User Preferences file & relaunched DDO.
Various check boxes in the Audio UI.
(That's about it, not exactly tech savvy here)

Running the DDO Mac client natively (not via Steam) on OSX Lion. Any help appreciated - especially if it doesn't involve an un- & re-instal of DDO ;)

I'm running on Yosemite with a HyperX Cloud headset.
Since the previous update it stopped working for me as well.
I've tried closing down the DDO Mac client and setting the OS to Internal speakers and internal microphone.
Upon restart this gives me the option to change the playback devices for Voice playback and capture.
After selecting this, I can switch the OS back to my USB headset.
This always worked to fix it till the previous version, then it stopped working.
It doesn't work with Update 35 either.
Something must have changed in the client, but it's beyond me to fix it.
I hope they manage to fix it because group play without voice is really annoying.

Kaytis
03-26-2017, 11:26 PM
I encountered this problem today. The voice capture and voice playback menus are greyed out and nothing can be selected. The game sounds playback can still be set to the headset however.

So I tried a number of things without any luck. And then I tried two things in a row and got it working again. Unfortunately I don't know which thing fixed it, but I assume if folks try them both, it should get their headsets working again.

I think the thing that most likely fixed it was this: open the "System Preferences / Sound" control panel. Switch to the Input tab and select "Internal Microphone". Switch to the Output tab and select "Internal Speakers". i.e. don't select your headset. Select the built-in mic and speakers instead.

Launch the game and see if the menus are active now. If they are, your headset should be available for selection in the menus.

If that doesn't work, open /Applications/Utilities/Audio MIDI Setup. Select your headset from the list on the left and change the sample rate to 44100 Hz -or if that is what it is, the highest value you can change it to that isn't 44100 Hz. Try DDO again and see if your device can be selected in the voice capture / playback menus now. I really don't think this was the thing that fixed it, but I have no way to tell at this point.

For the adventurous: Standing Stone renamed the prefs file to ~/Library/Preferences/com.standingstonegames.dndclient.plist. I noticed that the Voice.DeviceCapture value and the Voice.DevicePlayback were both set to -1 while it was broken. This is very likely an error flag indicating that no audio system was available -not just the headsets -but everything, which is why the menu was completely greyed out. I think resetting sound to the internal path fixed the problem by making the internal path stable again -thus the client was able to get past the built-in stuff and subsequently find and add the headset.

PermaBanned
07-17-2017, 02:02 AM
I've tried closing down the DDO Mac client and setting the OS to Internal speakers and internal microphone. Upon restart this gives me the option to change the playback devices for Voice playback and capture.
After selecting this, I can switch the OS back to my USB headset.


open the "System Preferences / Sound" control panel. Switch to the Input tab and select "Internal Microphone". Switch to the Output tab and select "Internal Speakers"
Thank you both, that indeed fixed it for me. Selection boxes no longer greyed out, and all settings back to normal & staying that way after restarts.


This always worked to fix it till the previous version, then it stopped working. It doesn't work with Update 35 either. Something must have changed in the client, but it's beyond me to fix it. I hope they manage to fix it because group play without voice is really annoying.
I only see 2 or 3 differences between mine working and yours not, after I followed your instructions.
• I'm still on OSX Lion, running the native DDO Mac client (not Steam).
• If hardware matters, I'm on a Mac Pro from 2006.
• Before coming here and seeing this I did a full DDO reinstall - though I suspect if I had read this first I wouldn't have needed to.

Posting this just after U36. Hope yours gets sorted out again :)