PDA

View Full Version : Mac user problem: installer/launcher not launching



dmoney20211
02-12-2015, 04:46 PM
Hello,

I had a working version of the game on my mac until an hour ago. Now when I go to launch the installer/launcher it flashes on for a second, the happy cloud starts (as usual) and then, it disappears. Please help.
Btw didn't download or change anything on my computer since the last time when it worked.

Thanks

Bashibozuk
02-12-2015, 04:56 PM
hi,

I am having the very same problem. I restarted my computer, uninstalled, reinstalled DDO Installer and finally received a "Logging Error" message: Failed to create HC loader log file. I hit OK and after a few seconds of initializing happy cloud window i got another message that stated that i need to download the latest version of happy cloud and when i hit download, nothing happens. Please resolve this issue.

Bashibozuk
02-12-2015, 05:27 PM
i have found a thread concerning the same problem in LOTRO forums, i haven't been able to try it yet but it might work for you.

https://www.lotro.com/forums/showthread.php?552010-My-Mac-wont-download-the-game

In your case -- Happy Cloud was what was being updated, which is not related to LOTRO.
1 - See: https://lotro-wiki.com/index.php/Mac...d_Installation

2- Completely delete Happy Cloud:

2a- /Applications/LOTRO Installer.app --- Happy Cloud Installer and HC client launcher
2b- /Users/Shared/Happycloud/ - parent directory for all Happy Cloud files
2c- Users/<username>/Library/Logs/DiagnosticReports/ -- Standard Apple location for dump files
2d- Depending upon where you designated the LOTRO client to be installed, it will be in a folder "Happy Cloud" on that device.
For example - installation on an external FireWire drive
/Volumes/FW09/HappyCloud/Cache/The Lord of the Rings Online(tm).app

3- Start over again. I would use the full downloader rather than "play instantly" (which you can't do anyway).

Bashibozuk
02-12-2015, 06:40 PM
As i was following the instructions above, i came across a file "Setup_HappyCloud_4.30.exe" which i think might be the updater downloaded when i hit download button earlier.
Since it is a windows executable file Mac OS won't launch it thus Happy Cloud isn't going to update and Launch the DDO Installer.
So far i tried to execute that file using an old version of Wine that was present on my computer without success.
If this is the issue Happy Cloud technical staff haven't foreseen and resolved the problems beforehand such an update may cause for Mac OS users.
Maybe DDO could contact and have this matter sorted but taking into account the storm they've recently weathered i am not sure it'd be this day.

Ayseifn
02-12-2015, 07:03 PM
Linux user here, this worked for me:


Well... let's see... it would be preferable to have someone test things on Windows or maybe even build a package to minimize the risk of error, which is considerable here (and no warranty whatsoever! I don't actually know what'll happen) but...

I cannot usefully test anything Windows-specific on Linux, obivously, but I'd think installing unpackaged Pylotro might go something like... here goes...


1) You need to have Python installed. Your old Pylotro package install will necessarily have come with it, but I'm not sure if it'd make sense to keep that.
So, I'd go and remove the old Pylotro, and install Python. https://www.python.org/downloads/ ... Pylotro recommends 3.2+ but I'm on 2.7 and it works fine for me.
2.7.(9+) and 3.4+ at least should come with "pip" and "setuptools", otherwise you'll need to get those separately, you'll probably need them.

2) Download the prerequisite package(s). Only PyQT4 is listed as absolutely required, http://www.lfd.uci.edu/~gohlke/pythonlibs/#pyqt4
- choose version corresponding to what you have from step 1.

3) Get a command prompt with Python in your path. Assuming you installed Python in "C:\Python27\", this is done by starting a command prompt (cmd.exe) and running command "set path=%path%;C:\Python27\" - change to match what you did earlier.

You should now have Python installed, and "python" and "pip" commands available from your command prompt window, if I got this right.

4) Run "pip install PyQt4?whatever-you-downloaded.whl" - assuming that is successful, you should then have PyQT4 to go with your Python.

5) Get the Pylotro source, direct link would seem to be https://github.com/nwestfal/pylotro/archive/master.zip , and unzip it in a suitable place locally.

6) Using the Python-augmented command prompt, go to wherever your unzipped Pylotro content is, and run "python setup.py install".



On Linux, I only needed to do parts 5 and 6, and that latter command produced the "pylotro" executable. Now, never having tried, I'm not at all sure what actually happens on Windows, but you should either get a "pylotro" command available to your command prompt, or maybe even a proper Windows-type graphical launcher in your menu somewhere.


Sources used:
http://www.lfd.uci.edu/~gohlke/pythonlibs/
https://pip.pypa.io/en/latest/user_guide.html#installing-from-wheels
http://www.instructables.com/id/How-to-install-Python-packages-on-Windows-7/
https://wiki.python.org/moin/Python2orPython3
https://docs.python.org/2/install/
https://docs.python.org/2/tutorial/interpreter.html

Xathris
02-12-2015, 07:34 PM
I can't get on either, and I am on a mac. What am I paying for? I hope they extend your subscription for all the downtime the game has.

dmoney20211
02-12-2015, 08:21 PM
Hey,

Thanks for info but nothing has worked. I've sent tickets to both happy cloud and ddo unfortunately have to wait a long time to get this resolved and my guild is busily having fun right now!
Anyway good luck in finding a solution.

Thanks again.

Xathris
02-12-2015, 08:37 PM
Hey,

Thanks for info but nothing has worked. I've sent tickets to both happy cloud and ddo unfortunately have to wait a long time to get this resolved and my guild is busily having fun right now!
Anyway good luck in finding a solution.

Thanks again.

Ditto...on everything. My newest character hasn't been even able to join the guild yet.

Minor
02-12-2015, 09:27 PM
Same issue here . . . . Frustrating . . .

Santadwarf
02-12-2015, 09:52 PM
Same issue, click the ddo desktop icon, it starts then turns off half a second later, please help. none of the ideas above seem to work.

Santadwarf
02-13-2015, 12:59 AM
Here is what I did...

1. delete/removed all DDO related files even Happy Cloud if you have it around from another game. I think Happy cloud might be the problem.

2. install LOTRO to get a good copy of Happy cloud.

3. right click Happy Cloud and tell it to Uninstall games.

4. go to the DDO site and reinstall DDO, the new Happy Cloud seems to have installed it just fine.

- Sanatadorff, Nothingto, Mrdana - Sarlona server

Bashibozuk
02-13-2015, 05:20 AM
Thanks Sanata!

Here is what i am doing:

1 - I tried the LOTRO workaround earlier but it didn't work. I think i should have cleaned up all the happy cloud files as you had.
2 - I started downloading LOTRO via "Play Instantly" and got the updated happy cloud installer. LOTRO_MAC_4.46
3 - I tried to launch DDO from "Play Instantly" but it forces me to download and install the outdated version of happy cloud namely DDO_MAC_3.60.
4 - I restored the DDO Installer app from my TRASH, it launched and started downloading.
5 - It seemed to download all DDO files again and I am at character selection screen now, happy cloud happily downloading files in the background.

*When i click happy cloud application it doesn't launch an interface where i can uninstall/delete all other games.
**Full download is not an option for me because Akamai doesn't install on my computer.

In the end i spent quite some time to figure out and find a makeshift solution to a frustrating problem.
I am reinstalling a 10GB game to update a download client which had a 4MB update package.

Thanks to all fellow DDO players who suffered and tried to find solutions to this problem.

Xathris
02-13-2015, 09:02 AM
Thanks Sanata!

Here is what i am doing:

1 - I tried the LOTRO workaround earlier but it didn't work. I think i should have cleaned up all the happy cloud files as you had.
2 - I started downloading LOTRO via "Play Instantly" and got the updated happy cloud installer. LOTRO_MAC_4.46
3 - I tried to launch DDO from "Play Instantly" but it forces me to download and install the outdated version of happy cloud namely DDO_MAC_3.60.
4 - I restored the DDO Installer app from my TRASH, it launched and started downloading.
5 - It seemed to download all DDO files again and I am at character selection screen now, happy cloud happily downloading files in the background.

*When i click happy cloud application it doesn't launch an interface where i can uninstall/delete all other games.
**Full download is not an option for me because Akamai doesn't install on my computer.

In the end i spent quite some time to figure out and find a makeshift solution to a frustrating problem.
I am reinstalling a 10GB game to update a download client which had a 4MB update package.

Thanks to all fellow DDO players who suffered and tried to find solutions to this problem.
All I had to do was re-download DDO, which of course takes forever, but now it's working.

dmoney20211
02-13-2015, 11:44 AM
Downloaded again... worked after download because loaded automatically. After logged out of game, can't reopen.

Xathris
02-13-2015, 11:59 AM
Downloaded again... worked after download because loaded automatically. After logged out of game, can't reopen.

That stinks. It worked for me.


EDIT: I did put the old installer in the trash.

Mithrielle
02-13-2015, 03:18 PM
I did try to reinstall, but that even seems to fail
(read: this is the first Mac I have and I work with windows based computers so a lot to learn)

I did reinstall the DDO installer, that did not help.
I tried to reinstall The Happy Cloud, I was not able to remove it due to being active (I checked active programs by command+option+esc and it was not listed there)

So anyone more ideas?

Mithrielle
02-13-2015, 03:39 PM
I did not wanted to quit and gave it one more try. I got a DDO_MAC_4.46.pkg (the old one was DDO_MAC_3.60.pkg) after installing that installer it launched and I am in game now!

Bashibozuk
02-14-2015, 03:52 AM
Them sneaky bees, they updated the Happy Cloud installer in complete silence, without a word of acknowledgement.
This thread would have been the perfect place to announce that they have looked into the problem and sorted it out.
And i also realized that Mac Technical Assistance is a users only part of the forums where users assist users.
I am a fresh Mac OS user as well, getting around in these uncharted territories can be an ardous journey.
Now that the crisis seem to be averted i would like to thank the fellow users and lurking tech staff.

Tricosene
02-14-2015, 07:21 AM
I had the same problem, but found a workaround that works for me.

There's an app in Users/Shared/Happycloud/Cache/ called Dungeons and Dragons Online. You can use this to start the game like normal.

Hope this works for others!

dmoney20211
02-16-2015, 08:28 AM
I finally got it to work on the second download. Don't know if i have the updated happy cloud version or not.

Mithrielle
03-26-2015, 04:19 PM
I had the same problem, but found a workaround that works for me.

There's an app in Users/Shared/Happycloud/Cache/ called Dungeons and Dragons Online. You can use this to start the game like normal.

Hope this works for others!

I did search in the finder for happycloud, found the folder and also the cache folder. From there it did launch as described above.

Thanks!

Tricosene
03-27-2015, 07:17 PM
I did search in the finder for happycloud, found the folder and also the cache folder. From there it did launch as described above.

Thanks!

Sweet! Glad it worked.

Jasper_Stone
03-28-2015, 07:56 PM
Same problem. Annoying. Had a working version when I checked in earlier on the week. I have a busy and full calendar, so i schedule my online time. Spent most of that time to try and identify and to fix this problem. waste of membership fee


Hello,

I had a working version of the game on my mac until an hour ago. Now when I go to launch the installer/launcher it flashes on for a second, the happy cloud starts (as usual) and then, it disappears. Please help.
Btw didn't download or change anything on my computer since the last time when it worked.

Thanks

Jasper_Stone
03-28-2015, 09:22 PM
Ok. So followed the delete through Happy Cloud and re downloaded. That worked. But my evening of game play basically gone. With schedule, really only one night to play...annoying.

Hello,

I had a working version of the game on my mac until an hour ago. Now when I go to launch the installer/launcher it flashes on for a second, the happy cloud starts (as usual) and then, it disappears. Please help.
Btw didn't download or change anything on my computer since the last time when it worked.

Thanks