PDA

View Full Version : Ice Storm Not working



Sam1313
10-06-2014, 06:40 PM
I'm currently in Gianthold on my Level 15 human wizard, casting Ice Storm it's only lasting for 2 seconds exactly. I know this cant be correct because it used to last at least 30 seconds or longer. I mean 50sp to cast something that doesn't do any damage because it dissipates so quickly can't be working as intended.

Toro12
10-06-2014, 06:47 PM
I'm currently in Gianthold on my Level 15 human wizard, casting Ice Storm it's only lasting for 2 seconds exactly. I know this cant be correct because it used to last at least 30 seconds or longer. I mean 50sp to cast something that doesn't do any damage because it dissipates so quickly can't be working as intended.


Are you casting a firewall , or gust of wind or cyclonic blast right after casting your ice storm?
How about summons ? Using an efferiti or air elementL?

Sam1313
10-06-2014, 09:26 PM
No I usually cast web then Ice storm then stand there and watch them die while my hire beats on them. I don't use a summons because they just agro stuff I am not ready to fight yet.

Paleus
10-07-2014, 06:13 AM
I'm currently in Gianthold on my Level 15 human wizard, casting Ice Storm it's only lasting for 2 seconds exactly. I know this cant be correct because it used to last at least 30 seconds or longer. I mean 50sp to cast something that doesn't do any damage because it dissipates so quickly can't be working as intended.

I would have expected something that was this notable a change to have made it to the general forums in a bug complaint. So I'm thinking it might be something on the user end that needs to be identified.

I would personally take the wizard to a low level quest, something like gamblers den, and go in naked test casting ice storm. It could be any number of causes, and like the other poster I'm thinking the most likely is a conflicting spell, possibly cast by a mob. Unfortunately I don't have any wizards atm to check myself. Once that can be eliminated as a cause its on to testing other causes or waiting for all holy ruckus to start in the general forums because that would be a significant nerf that wouldn't go unremarked for a long.

Wh070aa
10-07-2014, 07:01 AM
I used an ice storm wand on a artificer yesterday, seemed to work just fine.

Phaeton_Seraph
10-07-2014, 01:02 PM
OP, was this consistent, or in just one battle? It's possible that it could have been dispelled.

Sam1313
10-07-2014, 10:34 PM
OP, was this consistent, or in just one battle? It's possible that it could have been dispelled.

It appears to be only happening in Gianthold only. In the wilderness and in any quest in Gianthold, but in other quests outside of Gianthold I have no problem.