PDA

View Full Version : Lubuntu Wine and Pylotro, getting game error [128] Fatal error with DirectX



Drelak
04-12-2014, 03:30 PM
Hi,

I know there have been some Linux people here, so I humbly ask for help.
I have been light user of FedoraCore in my previous job, and now installed my first own linux,
Lubuntu 13.10.
My machine is Acer TravelMate 2413LCi, and the reson for the change was XP support ending.
http://www.laptopdirect.co.za/download/acer-travelmate-2410-series.php

I wanted to continue playing DDO, of course.
I tried to follow instructions here:
https://sites.google.com/site/leeslinuxblog/installing-ddo-in-wine

On my first try I installed Wine 1.4 from Lubuntu repository,
ran the command line commands, loaded fresh DDO install package from DDO home page,
loaded PyLotRO into the DDO folder inside the Wine c-drive and failed.

After that I understood that PyLotRo is Linux utillity, installed it into my home folder, and failed to get it to recognize my DDO folder.
Then I replaced Wine 1.4 with Wine 1.6. Now Pylotro found the DDO folder, but files did not match.

I deleted the DDO, and installed it again. Result was error saying data files were missing or could not be written to. That was true. Each time I ran the installer one more data file was successfully added.
Now I am stuck at the next stage:
Game error [128]: The game encountered a fatal DirectX issue while attempting to start.
Try a different screen resolution or bit depth. If that doesn't work, try new video drivers.

I have correct driver for the card, I have ran DDO on XP on this same machine, and DirectX 9 functionality should be provided by Wine 1.6, I have even tried to install d3dx9 dll:s with winetricks.
Please help!

Drelak
04-16-2014, 04:51 AM
After some days of trying it seems that it is impossible to run DDO through wine on my machine.
Reason seem to be the Intel graphics card:

Citing http://http://ubuntuforums.org/showthread.php?t=1969376 (http://ubuntuforums.org/showthread.php?t=1969376)

Linux/wine uses OpenGL, which Intel FAILS AT MISERABLY.

Intel, for whatever reason, only cares about D3D, and thru that, Windows.