View Full Version : Joystick support?

02-01-2013, 09:33 AM
Has anyone tried to use a joystick with the Mac client? I tried, but without success. I suppose this could be related to the keybinding issue, though?

07-18-2013, 07:01 PM
Just a wishful *bump*

Does the Mac client support joysticks? Has anyone else tried? This is the one feature that is keeping me from playing on a Mac. :)

07-25-2013, 03:04 PM
Just in case anyone ever wants to play with a joystick on a Mac in the future, I'll pass this along: I asked Turbine support, and they said that joysticks re indeed not supported on the Mac client. The recommendation I was given was to use a program to map joystick buttons and directions to keyboard keys, and then map those in the game. I tried this, and it works great.

08-27-2013, 02:30 AM
Thanks to Dire for the suggestion of using a 3rd party key mapping application.

I have been playing on windows for 5 years but recently gave up bootcamp, and needed to complete the conversion by getting the **** 360 controller working for the mac DDO client. I have neck and shoulder issues and can't play keyboard style for more than an hour without turning into a crippled hunchback, so I pretty much require the Xbox controller to play.

I was hoping to share my trials and tribulations hoping it could help others, and maybe someone else has figured out some things that I still have problems with.

As best as I could figure there are two main options on the App store to get the xbox controller working. It appears the more common app is called GamePad Companion and is the more expensive one ($8). The other is called Joystick Mapper, and is a bit cheaper ($5). I ended up downloading and buying both (though I later discovered that at least one was available on torrents.) Both of these apps require a necessary driver called tattiebogle be installed into system preferences. Get it here: http://tattiebogle.net/

Up to this point everything went smoothly. Then it came time to actually keymap, and the bloody nightmare started.
First let me start by warning you of two things upfront:

1) DDO claims to not allow remapping of the mouse buttons, but this is in fact FALSE. It's a massive problem, because if you accidentally remap your mouse buttons you can not do anything in game, not even log out! Everything requires being able to click on a button, including log out or quit. It's painfully easy to accidentally remap the mouse buttons, because when you click to map a key the next thing you do maps it. If you try to map something using the controller and nothing happens (not uncommon) then the small mapping window tells you to press escape to exit mapping. If you forget and try to click something rather than press escape then BAM you have just remapped your mouse click to do what you were trying to map and you are basically screwed. The only solution I could find was a force quit on DDO, which makes you lose all your changes, and you are starting from scratch again. What a bloody nightmare. I wish Turbine would fix this bug!

2) to the best that I have been able to figure out GamePad Companion CAN NOT MAP THE MODIFIER KEY! This is massively critical, though I have not been able to figure out why, it just doesn't do anything. Joystick Mapper does map the modifier key, though it is very glitchy. So to cut to the chase I recommend using Joystick Mapper rather than GamePad Companion, unless someone out there knows a way to map the modifier key using GamePad Companion, or you are willing to give up the mod key and lose half the functionality of the controller. So back to my story.

Because Joystick Mapper was a tad cheaper I had downloaded it first. Mapping was cumbersome because it required switching back and forth between DDO and the app. This required having the keyboard commands mapped in DDO first, then the functionality of the controller mapped button by button. Because I avoid using keyboard I try to eek out every single possible controller command, including the modified version of every button/axis. At first things started smoothly, but then I noticed that DDO mapping started behaving strangely as soon as I mapped the modifier key. The modifier key does work using Joystick Mapper, but strange glitches start to show up, and they seem to accumulate over time. After the modifier has been mapped then everything from that point on seems to be tainted with the modifier key name, regardless if it is a modified command or not. Also, every time you change Joystick Mapper the modifier key in DDO seems to glitch and needs to be remapped. Every time.

These constant glitches aside, through extensive trial and error I was eventually able to get almost everything mapped. Key trouble points came when mapping modified keys. DDO internal mapping seems to get crossed up with the 3rd party mapping, and I found that when this happens I have to remap either within DDO or externally in Joystick Mapper. Several times I had to reset DDO to defaults and start from scratch. Sometimes I found that I had to delete and remap individual keys/axis within Joystick Mapper and some problems went away. Eventually I was able to get all buttons, the hat and the left stick to map using the modifier. Unfortunately it appears the right stick, which I have mapped to emulate mouse movement, will not map using the modifier key for some reason.

Another detail I discovered is that the choice of what key to use as the modifier key matters. I think there are limited options, but did not have the patience to experiment too much. Using space bar did not work, but alt or shift did seem to work. Alt worked but caused problems with the rune arm. Shift worked but caused problems with block. I think I solved the problem by using shift as the mod and remapping block elsewhere.

After literally about 12 hours of trial and error attempts, failures, resets to default and repeat, I eventually got fed up with the glitches of Joystick Mapper and decided to spend the money and try GamePad Companion. Was disappointed to learn that I could not map the modifier key. Other than that it worked well, perhaps even better, but for me the modifier key is non-negotiable. So I gave up on GamePad Companion and went back to Joystick Mapper. I would be very interested to hear from anyone about solutions to the mod key mapping on GamePad Companion, or if anyone knows of any other mapper apps that could work. Also has anyone come across solutions to the remapping of the mouse buttons? I would think that others must have come across this mouse button glitch.

Hope that helps someone....

Cheers! and good luck
- Madman666