View Full Version : Client no worky...

12-10-2012, 09:26 AM
So yea, has anyone gotten the client to get to the character selection screen? I've tried on my work machine and home computer (they're both the same machine, with the same OS, so we might as well treat them as ONE machine) and both get me to the strange hatch pattern, then the game closes/crashes. I'm then presented with the opportunity to send a crash report to APPLE.

Mac Pro (2006)
5/10 GB RAM (work/home, respectively)
Nice, burly internet connections at both locations

Is the dev team wanting crash reports?

EDIT: It gets to "loading character data", then quits/crashes/hasSeizure

12-10-2012, 05:49 PM
The client worked for a few days at most. Then they updated it over the air for a new build. That update broke it.

The application is organized in two pieces: a launcher application, and buried deep in the launcher bundle, a completely separate client application. The launcher still works, but when it starts the client running, it is either handing bad command line arguments to it (doubtful -the params look fine to me), or the command line parser in the client is broken. I have seen traces that indicate that a low level string compare operation in the client is using NULL as a parameter, and the backtrace indicates that the command line args are being parsed when this happens.

Fortunately, the launcher still works. It will be possible to deploy a fix without having to download and install from a disk image again. I hope that happens soon. I was having fun with it while it worked.

12-11-2012, 01:01 PM
Well, I guess then that it would be silly to mention that the same problem occurs when using 10.8. Oh well.

And yet, we wait.

12-11-2012, 06:05 PM
I was hopeful to try this out, but no dice.

It was a big download and a bit fiddly to get it passed the gatekeeper but i managed to get the launcher started.
It did the updates, got to the login screen and then ....
An ugly checkerboard screen with a loading bar and nothing more but a crash.

We're happy to help improve this, let us know how ;-)

12-13-2012, 08:52 AM
Well, I guess then that it would be silly to mention that the same problem occurs when using 10.8. Oh well.

And yet, we wait.

I'm so excited about this it's ridiculous. I am now stuck with crashes where it says 'loading data'. My screen turns to a white and black grid as it's loading and then it crashes :(

I'm on 10.8 also.

I run the LOTRO mac client everyday now that it exists. I will play DDO again and no doubt use the store if this can work like the LOTRO one does.

So pumped. Just waiting for a working copy for teh mac.