PDA

View Full Version : Debugging info for devs re invisible on ship



EllisDee37
07-15-2012, 05:46 AM
The bug where you sometimes go invisible when going through a door on your ship just hit me while I was extending ship buffs and I noticed another odd display deal with hookpoints:

The bug hit me and I went invisible going to the upper deck, but I didn't care since it's just a display glitch. While invisible I turned on hookpoints and they showed normally, all green squares accounted for. When I went down below, I became visible again but now the green squares disappeared. Hookpoints were still functional; I got the timers when I walked over them, but they weren't showing on the floor.

Going through a door again and both I and the hookpoints were visible.

Just figured if this helped to identify the problem maybe worth a post. Wasn't sure where debugging info went so tossed it in here.

Tid12
07-15-2012, 06:19 AM
The hookpoint problems has been there for a long time.

Just re-exit and re-enter should fix it. I don't think it has anything to do with the invisible glitch.

GoRinNoSho
07-21-2012, 06:19 PM
The going invisible bug occurs anywhere where you can teleport within the same map. In the airship you teleport from the uppder deck area to the lower deck area.

The same effect can be achieved in slayer areas where there are multiple teleport areas, such as Orchard of the Meecrob. It has a lot of caves and tombs. Tend to be able to reproduce that issue at least once a rare circuit.

It ranges from completely invisible to only weapons. One interesting thing to note is if you switch weapons when completely invisible your weapon should at least show up and float in the air roughly marking your position. Monks aren't so lucky though.

MrkGrismer
07-23-2012, 09:41 AM
I suspect the going invisible bug has to do with the Druid wildshape tech, as on the ship when you use amenities you go invisible for an inordinate amount of time wile switching between shapes.