PDA

View Full Version : Devs, fix the dang lag issue once & for ever



Lagin
03-22-2012, 03:35 AM
Enough, I run a 40 mbps, have a gtx780 V-card that out-clocks this game, 8 G ram and since U12 the lag is horrendous,

Please provide an explanation or blow up the antiquated equipment, and get the digital engine in here asap.

Seriously, enough is enough. What will happen when most providers run 1Gbps?

The code engine we have is dragging this game in a downward spiral, you keep adding stuff to bottleneck the signal, and the load times keep increasing!

You nerfed stuff like twf to increase bandwidth, I was there for the Lama test, it worked great until the next patch. You keep adding more and more data to accommodate all the crafting/ animations etc... but dont address the core issue.

It's NOT client side!

And to take this rant one step further, running a V-card like I have, why isn't DDO listed on the enhanced video section?

Are we do for a total blow up like Blizzard gave it's customers? I hope so, because adding anything to what we have now will Hamstring the game to the point of losing more people than the expansion can bring in!

Lagin
03-22-2012, 03:42 AM
And IF I'm wrong, please point where myself & countless others can improve game performance.

Antheal
03-22-2012, 05:01 AM
Sometimes I honestly wonder if DDO was Turbine's very first attempt at making an MMORPG without really knowing what they were getting themselves into.

Does Lord of the Rings Online have this level of unplayability due to lag? Did Asheron's Call before that was abandoned? What about the MMORPGs of other companies? Does World of Warcraft, Guild Wars or Everquest have problems with lag on the same level as DDO?

If the problem isn't with the DDO servers then it must be with the patchwork code DDO is mashed together from.