PDA

View Full Version : Phantom Attack bug still in mod6?



gpk
12-14-2007, 09:28 PM
Well it seems the Phantom Attack bug is still there.
I'm chasign a very slow Rakshasa, basically humping is leg and no dice rolls.
As others have sugegsted before, the hitxbox does indeed seem to be in FRONT of the mob, as demonstrated by damage numbers when i was running ahead of mob and swinging.

http://i13.tinypic.com/85xuja0.jpg

P.S. 56 ms ping , 0% PL

Nevthial
12-14-2007, 09:30 PM
When I went with spring attack on one of my fighters, I noticed it went away for that character. He can chase 'em down and whack away getting hits. Just an observation.

Serpent
12-15-2007, 04:32 PM
had same thing happen against a slayer spider

GlassCannon
12-16-2007, 04:46 AM
This bug is why I don't play a melee class(anymore).

This bug is gamebreaking.

This bug got worse in MOD 4.

It may have something to do with Synch Errors between the Client and Server.

Nevthial
12-16-2007, 05:16 AM
Is it related to latency? Mine is normally only running around 40. Could this be why I don't see it as others do? My wife's computer usually has around a 69/70 and it happens to her sometimes. Our guildies see it alot though, but I'm not sure what their latency is. I'm a gazillion miles away from home right now so I can't find out.

gpk
12-16-2007, 05:44 AM
When I went with spring attack on one of my fighters, I noticed it went away for that character. He can chase 'em down and whack away getting hits. Just an observation.

Well I just tested with spring attack vs a tigerman again, same results: phantom attacks from behind, hits from in front.

http://i1.tinypic.com/872f807.jpg

P.S. Typically my ping is in the low 50s, as it was when I took these screenshots

Cyndder
12-16-2007, 05:50 AM
Be sure to post a bug report on this; add the url to this thread so they can see your great pics!!

Yvonne_Blacksword
12-17-2007, 10:19 AM
I find, if I am not hitting them while chasing them...if I swing while running beside them I hit.
Is that the bug?
Maybe...due to lag...(phantom lag)
You are trying to strike something you are not in range of..

Even though you have tread on its heals.

Mad_Bombardier
12-17-2007, 10:35 AM
I wouldn't call them phantom attacks so much bugged collision detection. You're attacking, but hitting when facing the wrong direction. To use the old place numbers:
(front)
123
4_5
678
(rear)

Hits are only being registered (regardless of player facing) when you are in spaces 1-5 on a moving mob. No rolls for spaces 6-8.

Raithe
12-17-2007, 11:02 AM
I suspect it has more to do with the amount of processor activity on the server, rather than the ping time and processor load of the client. I generally have ping times around 120ms, and I don't seem to have much of a problem with hitbox estimates even while on my spring attack fighter.

I don't consider this a game-breaking "bug." Melee chasing mobs who are running away should be a complete rarity anyway.