PDA

View Full Version : Store hot key



Pwesiela
09-03-2009, 08:50 PM
Posting here because I can't find a "store" thread.

I reported this in Beta, but evidently it was another one of those bugs that never got fixed.

The store has a default hotkey of ctrl + s. The left ctrl also happens to be my push to talk for vent. As such, whenever I run backwards while talking in vent, the store pops up. Now, I think to myself, guess I'll need to change the key binding for the store. So I do, changing it to ctrl + b. Relog the game and guess what? Yup, it's still ctrl +b, but ctrl +s has added itself back onto the key binding. So I put in ctrl + b and a secondary hotkey of ctrl +y. Relog, and guess what. Yup, it's back to being ctrl +s.

What's up with this Turbine? Can't have the store on anything other than ctrl +s?

Fix please. I like my hot keys staying the way I want them to be, and not deciding they know more than me about how I want to organize myself.

Thanks.

captain1z
09-03-2009, 08:51 PM
sorry didnt read the op b4 posting....nvm

Pwesiela
09-04-2009, 01:11 AM
sorry didnt read the op b4 posting....nvm

:confused:

Tickler
09-04-2009, 01:26 AM
Yep, I'm having the exact same issue. Lets get this fixed Turbine.

Finthis
09-04-2009, 10:10 AM
Hi Pwesiela -- We did devote some time to investigating this bug in beta, but could not find any root cause for it. Also, we could not reproduce the bug locally. I don't think it has anything to do with the store in particular...could you attempt to set other keymappings within game, quit, log back in, and see if they have been saved? I suspect this has something to do with permissions on the keymap file -- you make the changes in game, but are not allowed to save the file, so they are reverted when you log back in. It sounds like you have changed your keymappings in the past and they have stuck though, which is why this problem seems especially strange.

Things you (and others experiencing this problem) could do to help:
* See if you can change other keymappings successfully
* Check your ddo.keymap and userpreferences.ini file, which should be located in documents and settings\(username)\My Documents\Dungeons and Dragons Online -- are they read only? Do you have permissions to write to them?

Thanks!

Bogenbroom
09-04-2009, 10:48 AM
I just experimented with this a smidge, as I use cntl as my push-to-talk button. I can remap fine, and it works great as long as I am in game. However if I quit and log back in then...

- If I only have a primary mapping cntl-S will be added back in as an alternate mapping (and yes, I did clear first,) or
- If both primary and secondary are filled, that will still be as I left them, but cntl-S *still* opens the store.

Then I tried remapping my help key from "H" to "?" (or shift-/) and that worked entirely as expected. Logged out and back in and "?" and only "?" got me the help menu.

Hope that helps.

tihocan
09-04-2009, 12:24 PM
Check in the keymap file and see if you can manually edit it, then launch the game (might still revert it back, but it's worth a try).

riexau
09-04-2009, 01:52 PM
I'm having the same problem with my push to talk keybind. it's stuck on F and there's no way to get it off.

Whenever I relog, it gets put back. I've done it both in game and manually in the keybind file.

Only thing I haven't tried is changing it out of game and making the keybind file to read only...

Hafeal
09-04-2009, 02:17 PM
I recently loaded vent and made the left ctrl key my vent key as well; I had no problem mapping it or it staying that way. I had no problem with DDO Store re-mapping either. In fact, I have re-mapped keys several times in order to figure out what I like best.

Missing_Minds
09-04-2009, 05:47 PM
I had an issue VERY simliar to this. Mouse Camera however.

No amount of working n the key binding would actually change it. Heck, it was even reporting the correct keys in the UI, but that is not what was actually working.

Luckly I had some old key files in backup that I tend to make monthly.

After doing a comparison, I was able to manually fix it. There is a bug in their UI keyfile storage, and I did report it with a LOT of data. I'm a bit bummed they didn't fix it. I mean it shouldn't be that difficult to figure out key binds and write them to a file.

Any who, post your keyfile. We can probably figure out which line/s got not corrected and tell you how to fix it.

Gemini_II
09-04-2009, 06:55 PM
I have this same issue but with different keymapping. I set my PTT button to "V" and I can successfully map it in the options menu, but whenever I relog, the default of "F" re-appears, no matter how many time I clear it.

What it looks like is that the defaults are getting appended to our keymap settings upon login. Last time I played around I cleared all PTT binds and just set it to V. On relog V was secondary and F was back to primary.

Pwesiela
09-05-2009, 12:15 AM
Hi Pwesiela -- We did devote some time to investigating this bug in beta, but could not find any root cause for it. Also, we could not reproduce the bug locally. I don't think it has anything to do with the store in particular...could you attempt to set other keymappings within game, quit, log back in, and see if they have been saved? I suspect this has something to do with permissions on the keymap file -- you make the changes in game, but are not allowed to save the file, so they are reverted when you log back in. It sounds like you have changed your keymappings in the past and they have stuck though, which is why this problem seems especially strange.

Things you (and others experiencing this problem) could do to help:
* See if you can change other keymappings successfully
* Check your ddo.keymap and userpreferences.ini file, which should be located in documents and settings\(username)\My Documents\Dungeons and Dragons Online -- are they read only? Do you have permissions to write to them?

Thanks!

I'll take a look at these later tonight when I have some time and let you know what I find.

riexau
09-05-2009, 10:10 PM
I have this same issue but with different keymapping. I set my PTT button to "V" and I can successfully map it in the options menu, but whenever I relog, the default of "F" re-appears, no matter how many time I clear it.

What it looks like is that the defaults are getting appended to our keymap settings upon login. Last time I played around I cleared all PTT binds and just set it to V. On relog V was secondary and F was back to primary.

Yep, and making the keymap file read only doesn't help :(

This was definately not the case pre-mod9.

Pwesiela
09-06-2009, 03:30 PM
I'll take a look at these later tonight when I have some time and let you know what I find.

OK, I took a look. Neither of the two you suggested did anything. The store still reverts while all other mappings remain the same. Even if I change them to something else. Additionally, adding new key maps also held (added some for spells on my cleric for easier access). Both the user interface and key mapping files are set to be written on. I'm not sure what's going on here, but it's annoying.

:confused:

tinyelvis
09-06-2009, 03:54 PM
I didnt read thru whole thread but Just want to say a big,

DITO

Small annoying problem to have to reset keymap every time I log in.

smithers
09-08-2009, 01:18 PM
I've died twice now as a result of this.

For me, Ctrl is "block", and with my mappings getting overwritten each session, any time I try to tumble back out of combat I see "DDO Store" trying to sell me a rez cake lol.

Archguru
09-08-2009, 01:51 PM
Also having the same issue.

Single bind and double binds still revert to ctrl-s.

Braegan
09-08-2009, 01:56 PM
Same issue here, likewise none of the above suggestions worked.

Rantanplan
09-08-2009, 02:53 PM
Same Issue here in DDO:U and DDO EU, you canĀ“t change push-to-talk auttotargeting and mouselook.

Strakeln
09-08-2009, 02:58 PM
* See if you can change other keymappings successfully
I have been able to do so all over the place. In fact, my re-mapping for the DDO store saves correctly... the problem is that "ctrl+s" gets auto-remapped back in every time I log.

Actually, now that I think about it, I'm pretty sure it's only upon launch, not log.


* Check your ddo.keymap and userpreferences.ini file, which should be located in documents and settings\(username)\My Documents\Dungeons and Dragons Online -- are they read only? Do you have permissions to write to them?
I have write permission.

Of note: after installing DDO:EU, I copied my old keymap file over the freshly installed one. Presumably, logging on causes updates to this file (otherwise, how would things like "DDO store" show up in there, when they weren't there before). Might this relate to the issue? This also might explain why some see the problem and some have no problem. Off the top of my head, here's an example scenario:

1) ddo.keymap has a version identifier in it (again, this is an example, not sure if this is true)

2) Launcher checks the version of the file, and if not the current version, adds in new fields/deletes old fields/copies settings from deprecated options to their new equivalent.

3) Launcher fails to update the version number of ddo.keymap before closing the file.

4) User removes "ctrl+s" in-game

5) Next time game is launched, step #2 occurs again.

You know what? I bet this is really close to what is happening. On my one computer where I have repeatedly remapped this, every time I launch (from the taskbar) for the 1st time in an evening, I get some kind of "unable to update" or "update failed" message. Re-launching (from scratch) fixes the problem, and I notice that it is taking extra time at the "examine programs" checkmark.

...but on my other computer, where I do not remap the store hotkey, I never see this problem.

I'll see what happens if I remap the keys on the other computer. I betcha the problem is pretty similar to my example, though.

Finthis
09-08-2009, 03:12 PM
Hey everyone - thanks for all the information you have provided! It has made me think of a few things that we have changed, and given me a new lead on figuring out this issue. I will continue to look into this.

Pwesiela
09-08-2009, 03:22 PM
Hey everyone - thanks for all the information you have provided! It has made me think of a few things that we have changed, and given me a new lead on figuring out this issue. I will continue to look into this.

Much appreciated Finthis. While I haven't died yet as a result of this, I've gotten really uncomfortably close...:eek:

Dirkan
09-08-2009, 04:31 PM
I am having the same issue. Everytime I log back in the Key mapping has reverted Cntrl - S. It is very annoying. Another guildmate has complained about the samething.

Lifespawn
09-08-2009, 04:40 PM
2 guildies having the same issuse but with diff keys 1 has ctrl as his ptt for vent and the same thing ctrl plus moving backwards = store popup.

The other has B set to talk for teamspeak and ingame default is b so we get an echo he changes it fine but when he logs out and back in it's reverted.

DasLurch
09-09-2009, 05:08 AM
Posting here because I can't find a "store" thread.

I reported this in Beta, but evidently it was another one of those bugs that never got fixed.

The store has a default hotkey of ctrl + s. The left ctrl also happens to be my push to talk for vent. As such, whenever I run backwards while talking in vent, the store pops up. Now, I think to myself, guess I'll need to change the key binding for the store. So I do, changing it to ctrl + b. Relog the game and guess what? Yup, it's still ctrl +b, but ctrl +s has added itself back onto the key binding. So I put in ctrl + b and a secondary hotkey of ctrl +y. Relog, and guess what. Yup, it's back to being ctrl +s.

What's up with this Turbine? Can't have the store on anything other than ctrl +s?

Fix please. I like my hot keys staying the way I want them to be, and not deciding they know more than me about how I want to organize myself.

Thanks.

I use that "control" key for push-to-talk as well. I's only been a week and I'm tired of constantly re-setting my keybinds concerning the store. It's great and all, but does it always have to re-bind? Isn't the icon on the hotbar enough?

wyld00
09-16-2009, 06:36 PM
Any hotkey I set in game gets added correctly and persists when I relog.

Any hotkey I CLEAR in game only gets cleared for that session and COMES BACK when I relog. For example, I use mouse4 for Push-to-Mute in Vent so every time I want to mute my mic, I start Auto-Running.

I looked in the ddo.keybind file and it looks correct (I changed it to be ONLY Num-Lock):
MovementRunLock [ User [ 0 DIK_NUMLOCK ] ]

But it looks like the game does not properly configure the values from the loaded file when it starts. All of the default keybinds come back in addition to the ones I set. After logging, the UI shows my Num-Lock as the first key and then for some reason automatically adds "R" for the secondary one.

This is terribly annoying.

Combak
10-01-2009, 01:21 PM
I have a question how are you looking at your keymap file? When I try to open mine I get a error from windows that it can't open that type of file. The file type is listed as "KEYMAP file".

Would really like to get a look at it as I am having the same problems with defaults being reset everytime I start the game.

I reset a ton of keys and it is a pain to have to look at each time and see which ones got changed this time. Mouse look is always reset back to T.

thanks in advance.

later

Strakeln
10-01-2009, 04:15 PM
I have a question how are you looking at your keymap file? When I try to open mine I get a error from windows that it can't open that type of file. The file type is listed as "KEYMAP file".

Would really like to get a look at it as I am having the same problems with defaults being reset everytime I start the game.

I reset a ton of keys and it is a pain to have to look at each time and see which ones got changed this time. Mouse look is always reset back to T.

thanks in advance.

later
Tell Windows to treat it as a text file, and then you'll be able to view it.

Combak
10-01-2009, 06:40 PM
Tell Windows to treat it as a text file, and then you'll be able to view it.

Thanks

wyld00
10-09-2009, 09:01 PM
Finthis-

Any update? This is annoying the **** outta me :)

Halock
10-09-2009, 09:26 PM
I'm having the same problem, have had it since the store was put in, specifically this


I have been able to do so all over the place. In fact, my re-mapping for the DDO store saves correctly... the problem is that "ctrl+s" gets auto-remapped back in every time I log.

Its the only keymap i have tried that does this, i have even tried to keymap the store to 2 other buttons ( alt+s, numberpad 5 ) and its holds untill i restart my client, then it reverts back to ctrl+s, leaving one of my other keymaps for it intact.

Would love to see this bug taken care of.

wyld00
10-12-2009, 12:02 AM
Bump

wyld00
10-12-2009, 12:03 AM
what do we need to do to get an update from the devs on this? any response would be awesome. ive put in tickets and get no support whatsoever.

Pwesiela
10-12-2009, 11:19 AM
what do we need to do to get an update from the devs on this? any response would be awesome. ive put in tickets and get no support whatsoever.

If they're bug report tickets, you won't get a response. If it's a GM ticket, they may consider it a bug ('cause it is) and not deal with it. It's still highly frustrating.

wyld00
10-28-2009, 07:40 PM
BUMP even with update 1, this is still not listed as a known issue.

Ereshkigal
10-28-2009, 08:17 PM
Posting here because I can't find a "store" thread.

I reported this in Beta, but evidently it was another one of those bugs that never got fixed.

The store has a default hotkey of ctrl + s. The left ctrl also happens to be my push to talk for vent. As such, whenever I run backwards while talking in vent, the store pops up. Now, I think to myself, guess I'll need to change the key binding for the store. So I do, changing it to ctrl + b. Relog the game and guess what? Yup, it's still ctrl +b, but ctrl +s has added itself back onto the key binding. So I put in ctrl + b and a secondary hotkey of ctrl +y. Relog, and guess what. Yup, it's back to being ctrl +s.

What's up with this Turbine? Can't have the store on anything other than ctrl +s?

Fix please. I like my hot keys staying the way I want them to be, and not deciding they know more than me about how I want to organize myself.

Thanks.

get yourself one of these (http://www.amazon.com/Saitek-PZ31A-Cyborg-Command-Unit/dp/B000BU0F5Y). I don't think I would even want to play ddo without one now.

Rrend
10-28-2009, 10:16 PM
/signed

I'm to the point where everytime I log, the first thing I have to do is reset ddo store hotkey. Ridiculously irritating.

lorthean
10-28-2009, 11:37 PM
I have the same issue. When I log onto any character I must first change the DDO store key. I also use the same key to talk and use keys close to the S to run/move. Please find a way to fix this.....it really gets annoying when you switch characters quickly and jump into a quest "running" and suddenly the DDO store pops up when you are in a fight. :eek:

Why have a hotkey at all, use the bar at the top of the screen.

Thanks for any efforts put into this matter. I have been using the same keys to talk/play/run etc. for 3 years. I would rather not change my current method. :(:(

Letrii
10-29-2009, 12:45 AM
If they can't make it keep overwriting keymap, how about changing key combo it sticks you with?

oberon131313
10-29-2009, 12:46 AM
Much appreciated Finthis. While I haven't died yet as a result of this, I've gotten really uncomfortably close...:eek:

I have, since my vent key is left control, and backwards is "s", and my halfly wiz is gimped on hitpoints... :o

pragma
11-02-2009, 01:02 AM
This is happening to me as well as has been since mod9. I can confirm what others have said. Basicly, I can add any additional bindings I want, but cant clear ANY of the game's default bindings. Note that this issue has persisted for me through a switch from vista64 to win7-64, with a complete reformat and reinstall of the game. Needless to say, this is not a local issue, but a bug in the game.

A few important notes:

- I reinstalled from a mod8 installer I had downloaded some time ago and saved. But did not copy of any of my old keymap files or ini files. Also, I use classic keymapping, not the new one.

- The keymap file DOES SAVE CORRECTLY ON GAME EXIT. I can clear the annoying bindings, exit the game, and when I open the .keymap its correct

- The problem certainly occur WHEN THE GAME IS LOADED. Basicly, the game is taking a my correct keymap, and re-inserting all of the removed bindings into it, making an aggregate new keymap.

- This has ASBOLUTELY NOTHING to do with read/write permissions, or administrative access. I run the game as an administrator, and additionally, as I have said above, the file saves fine, its the LOADING of the keymap that is borked.

In a nutshell, Im fairly confident that what is happening here is that the game THINKS that my keymap file is an old mod8 one, and stupidly tries to 'update' it to mod9 version for me, when in fact if it would simply leave the damn thing alone we would all be fine.

Devs this problem is extremely simply to reproduce, I refuse to believe your failing to reproduce it. Worst case, please do exactly what I just did, and I am highly confident the problem will manifest. Remove the game from you PC entirely, then install fresh using the mod8 installer. Once in game, change the binding style to classic (it will default to the new style even with a mod8 installer) and attempt to change the move up key from W to ONLY the up arrow (not both). By this i mean CLEAR the existing binding to W, and then after it shows no binding at all, bind it to UPARROW. Close the game, and reopen the game. You will see that move up is now bound to BOTH W and UPARROW

Jacoby
11-02-2009, 09:22 AM
Here was my experirnce.

During a lag spike or something I went into mouse look mode. It froze there. I could turn it off by pressing "t" but as soon as I hit my left mouse button to navigate it would stick again. Logging out did not fix but when I alt - F4'd the prblem went away and hasn't come back. This happened the first day of update 1 (MOD10).

Cortho
11-02-2009, 09:34 AM
I have this problem also, If I push to talk as I run backwards Iget the ddo store. It resets every Time I log in. I will hit the coin when I want the store please get rid of this shortcut, or make it possible to change it.

Phiinix
11-05-2009, 11:59 PM
Ok, playing around with my keymapping, I have figured out a workaround.

For the keys that you want unbound, bind it to two existing keys. So for the DDO store, bind it to 1 and then to 2. Next, bind the 1 and 2 keys back to what they need to be. Viola! DDO store is no longer bound!

Haven't looked into what is being saved to the keybind file, but I don't really care if this works.

Tested this with a complete close and re-start of DDO, and the keys remain unbound.

Pwesiela
11-06-2009, 01:40 AM
For the keys that you want unbound, bind it to two existing keys. So for the DDO store, bind it to 1 and then to 2. Next, bind the 1 and 2 keys back to what they need to be. Viola! DDO store is no longer bound!

Not sure I'm following you on this. You mean I need to bind ctrl+s to do something else and then rebind whatever I bound it to?

Strakeln
11-06-2009, 10:59 AM
Not sure I'm following you on this. You mean I need to bind ctrl+s to do something else and then rebind whatever I bound it to?
If I'm reading it correctly, it sounds like this:

1) Clear out your DDO Store mappings
2) Map DDO store to something you already use, such as buttons 1 and 2
3) Then go to whatever you had buttons 1 and 2 mapped to and re-map them as they were. This will cause DDO Store to automatically un-map from buttons 1 and 2.

Then, somehow, this problem is automagically fixed.

I'll give it a whirl tonight, why not.

ChaosTheEternal
11-14-2009, 09:54 AM
My issue wasn't with the DDO Store key binding, but with Auto Run (which joyously binds to Button 4 on my mouse, which I never bound in DDO, which I use for PTT in Vent). Every time I would restart my client, my key bindings would list:


[ Auto Run ] Button 2 R [reset]
Which I had done intentionally, making clicking my mousewheel or pressing R do auto run. Problem was, every time I'd log back in, I'd end up with 3 keys bound to Auto Run, with Button 4 as the third, hidden bind. If I just flat out cleared Auto Run, every time I quit and come back on, Button 4 is the only one that is bound to it.

I tried messing with the key bindings like Phiinix suggested, tried editing the keymap file directly, no go. All I could do was basically map Button 4 to a not-so-important binding. In my case, it was Loot All. No error message for pressing it while not at a chest, so it works fine for me.

Having it set as a binding to something does prevent it from resetting. If you didn't bind two keys to Loot All, you could bind Ctrl+S to "Loot All" to keep the DDO Store from rebinding on launch.



The only issue I'm left with when logging in now is it showing Button 1 mapped twice on the "Attack" binding, but that's not causing any problems.

JOTMON
11-14-2009, 11:11 AM
The ctrl-S combo is definitely a pain.
everytime I login with every toon I have to remember to remove the ctrl-S binding.
I changed the store to a different bind key and guess what... it changed back as soon as I logged out.
Would appreciate it if DDO would allow the changed binding key to stick.
The last thing I want is to have the store pop up while I am backpeddling away from an oncoming mob.
It has gotten me killed on more than one occasion.

Pwesiela
11-15-2009, 12:40 AM
Any additional word, oh Dev-ious ones?

Siro
12-14-2009, 08:34 AM
Any additional word, oh Dev-ious ones?

I would like to know this is as well.

SickCat
01-07-2010, 12:34 PM
I suppose I'll plop my experience with this bug in here as well. I play on two different computers...both have the same issue.

I remap BLOCK to shift+space since I use shift+1, 2, 3, 4, and 5 as alternate hot keys for other abilities. Whenever I restart the game, I have to reset BLOCK to shift+space or instead of using Fist of Light (shift+1) the monk just blocks.

I want the '`' key for auto-run, but upon login, 'r' is back in there along with '`'. I use 'r' for mouselook on one of the computers.

On my home machine, I don't want there to be a mouse look button AT ALL...so I clear it out. But whenever I start the game, the middle mouse button turns on mouse look...even though there's NO key set in the binding. I have to set it specifically to the middle mouse button, and then clear it again.

The Toggle Auto-Targetting button reverts to shift+g and 'g' even though I clear out 'g'. When I fat-finger the keyboard (this happens a LOT) I accidentally turn off auto-targetting...which I absolutely don't want. I have to clear the bindings and put shift+g in.

I've reset Interact to 'x' as well as Select Nearest Target to shift+tab...they both work right and STAY right on both computers.

-Qetsil/SickCat of Thelanis

Siro
01-08-2010, 11:27 AM
I suppose I'll plop my experience with this bug in here as well. I play on two different computers...both have the same issue.

I remap BLOCK to shift+space since I use shift+1, 2, 3, 4, and 5 as alternate hot keys for other abilities. Whenever I restart the game, I have to reset BLOCK to shift+space or instead of using Fist of Light (shift+1) the monk just blocks.

I want the '`' key for auto-run, but upon login, 'r' is back in there along with '`'. I use 'r' for mouselook on one of the computers.

On my home machine, I don't want there to be a mouse look button AT ALL...so I clear it out. But whenever I start the game, the middle mouse button turns on mouse look...even though there's NO key set in the binding. I have to set it specifically to the middle mouse button, and then clear it again.

The Toggle Auto-Targetting button reverts to shift+g and 'g' even though I clear out 'g'. When I fat-finger the keyboard (this happens a LOT) I accidentally turn off auto-targetting...which I absolutely don't want. I have to clear the bindings and put shift+g in.

I've reset Interact to 'x' as well as Select Nearest Target to shift+tab...they both work right and STAY right on both computers.

-Qetsil/SickCat of Thelanis

After a LOT of testing and searching the forums, I found that one can assign those keys that keep reassigning themselves to something like hireling bar 5 to prevent them from being reassigned to their default keys.

So to prevent shift from being used by itself as block, assign shift by itself to one of those hireling bars, along with g, r, t and middle mouse, etc. It is a workaround, but not a fix. I don't expect to see this fixed any time soon, as it is still not a 'known issue' despite months of being reported as a bug and tacit acknowledgment by a dev.

dredre9987
11-02-2010, 04:06 PM
This is still happening. Keymap file is not saving any of my keymaps when i close the client. I come back on and everything is back to default...

Backley
02-14-2011, 04:56 AM
Ok, playing around with my keymapping, I have figured out a workaround.

For the keys that you want unbound, bind it to two existing keys. So for the DDO store, bind it to 1 and then to 2. Next, bind the 1 and 2 keys back to what they need to be. Viola! DDO store is no longer bound!

Haven't looked into what is being saved to the keybind file, but I don't really care if this works.

Tested this with a complete close and re-start of DDO, and the keys remain unbound.

Thanks Phiinix! This has worked perfectly for me for months now.

Steps:
1. Open Options, Key Mapping.
2. Note 2 keys that you are using. I used W ("Move Forward") and S ("Move Backwards").
3. Set "DDO Store" to both of those keys: Click "DDO Store" in the Panels section, press W, click "DDO Store" again, press S.
4. Set those 2 buttons back where they belong: Click "Move Forward" and press W, click "Move Backwards" and press S.
5. Close the Options window. Close the game. Backup your My Documents\Dungeons and Dragons Online\ddo.keymap file in case this ever stops working.
6. (optional) Repeat for "MyDDO Browser" or any other default settings you want to remove.

FYI, this is what that does in my ddo.keymap file (don't know if you can just edit that directly for the same effect):
Deletes

WEBSTORE_SHORTCUT_KEY [ Old [ 0 DIK_S ] 0x00000002 ]
MYDDO_SHORTCUT_KEY [ Old [ 0 DIK_M ] 0x00000002 ]


Adds

DoNothing [ User [ 0 DIK_S ] 0x00000002 ]
DoNothing [ User [ 0 DIK_M ] 0x00000002 ]

donfilibuster
02-14-2011, 05:33 AM
This is still happening. Keymap file is not saving any of my keymaps when i close the client. I come back on and everything is back to default...

The next time you open the game it will try to load the default keys again.
There's two things to do:

1. go to the fifth hireling bar and add ctrl-s to it.
(or some key that you will never use, which will do nothing when pressed)
do the same for the other default keys you want to remove.

2. go to the ddo.keymap file and make it read-only so that your new store key isn't erased.

Backley
02-14-2011, 05:39 AM
The next time you open the game it will try to load the default keys again.
There's two things to do:

1. go to the fifth hireling bar and add ctrl-s to it.
(or some key that you will never use, which will do nothing when pressed)
do the same for the other default keys you want to remove.

2. go to the ddo.keymap file and make it read-only so that your new store key isn't erased.

Why not just follow the steps I posted?

donfilibuster
02-14-2011, 06:22 AM
Why not just follow the steps I posted?

Looks good as long as DoNothing gets added to the file.

Then just make sure the file is set to read-only, because updates can still overwrite them.

Anthorin
02-14-2011, 06:32 AM
My issue wasn't with the DDO Store key binding, but with Auto Run (which joyously binds to Button 4 on my mouse, which I never bound in DDO, which I use for PTT in Vent). Every time I would restart my client, my key bindings would list:


[ Auto Run ] Button 2 R [reset]
Which I had done intentionally, making clicking my mousewheel or pressing R do auto run. Problem was, every time I'd log back in, I'd end up with 3 keys bound to Auto Run, with Button 4 as the third, hidden bind. If I just flat out cleared Auto Run, every time I quit and come back on, Button 4 is the only one that is bound to it.

I tried messing with the key bindings like Phiinix suggested, tried editing the keymap file directly, no go. All I could do was basically map Button 4 to a not-so-important binding. In my case, it was Loot All. No error message for pressing it while not at a chest, so it works fine for me.

Having it set as a binding to something does prevent it from resetting. If you didn't bind two keys to Loot All, you could bind Ctrl+S to "Loot All" to keep the DDO Store from rebinding on launch.



The only issue I'm left with when logging in now is it showing Button 1 mapped twice on the "Attack" binding, but that's not causing any problems.


Me too. Drives me nuts that I cant get rid of this and the autorun keeps coming back regardless of what I do.